summaryrefslogtreecommitdiff
path: root/Biz/Bild.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-12-21 10:40:06 -0400
committerBen Sima <ben@bsima.me>2024-12-21 09:40:06 -0500
commit79390d4eea20ca15fd8e088345528f31ed5fad1e (patch)
treef08b71ffddead23484fd6df9e1aff54d20f12768 /Biz/Bild.nix
parent18956baad9cde85bc55bd0113092e51786d9e1ee (diff)
Upgrade to nixos-24.05
I think this is the only "supported" nixos version now. But in any case scipy seemed to be broken on the older version, and I couldn't build my code that uses llm. Also, this allows me to get rid of the bild.os-unstable thing for Beryllium, which was just a sitting timebomb of breaking stuff. There are a lot of changes here because ruff updated to the very latest, and it changed some minor lint things. Also with the new nixos I get a proper cgit module, and some other breaking changes needed fixing.
Diffstat (limited to 'Biz/Bild.nix')
-rw-r--r--Biz/Bild.nix33
1 files changed, 16 insertions, 17 deletions
diff --git a/Biz/Bild.nix b/Biz/Bild.nix
index bc235bf..8e33d93 100644
--- a/Biz/Bild.nix
+++ b/Biz/Bild.nix
@@ -4,14 +4,14 @@ let
constants = import ./Bild/Constants.nix;
# expose some attrs from stable, keep this minimal and simple
- stable = {
- inherit (nixpkgs.nixos-23_11)
- sources lib makeWrapper ccacheStdenv haskell lispPackages_new python3
- nixos mkShell dockerTools pkgs;
- stdenv = nixpkgs.nixos-23_11.ccacheStdenv;
+ stable = let stable = nixpkgs.nixos-24_05;
+ in {
+ inherit (stable)
+ sources lib makeWrapper ccacheStdenv haskell sbcl python3 nixos mkShell
+ dockerTools pkgs;
+ stdenv = stable.ccacheStdenv;
};
- # just needed for running ollama
unstable = nixpkgs.nixos-unstable-small;
# this is the main library definitions, recursive references can be made with
@@ -65,7 +65,7 @@ let
]);
};
- lisp = { sbclWith = stable.lispPackages_new.sbclWithPackages; };
+ lisp = { sbclWith = stable.sbcl.withPackages; };
python = {
packages = stable.python3.pkgs;
@@ -80,14 +80,14 @@ let
# exposed packages for inclusion in builds
pkgs = with stable.pkgs; {
inherit bat bc cmark universal-ctags deadnix fd figlet fzf git
- git-branchless gitlint guile hlint indent jq lolcat mypy nixfmt ormolu
- pkg-config ripgrep rustc tree wemux;
- llama-cpp = nixpkgs.nixos-unstable-small.llama-cpp;
- llm = nixpkgs.nixos-unstable-small.llm.withPlugins
- [ nixpkgs.nixos-unstable-small.python3.pkgs.llm-ollama ];
- ollama = nixpkgs.nixos-unstable-small.ollama;
- ruff = nixpkgs.nixos-unstable-small.ruff;
- shellcheck = nixpkgs.nixos-unstable-small.shellcheck;
+ git-branchless gitlint groff guile hlint indent jq lolcat mypy nixfmt
+ ormolu pkg-config ripgrep rustc tree wemux;
+ llama-cpp = unstable.llama-cpp;
+ llm = python3.withPackages
+ (p: with p; [ p.llm-ollama ]);
+ ollama = unstable.ollama;
+ ruff = unstable.ruff;
+ shellcheck = unstable.shellcheck;
};
# a standard nix build for bild, for bootstrapping. this should be the only
@@ -106,7 +106,7 @@ let
# lisp deps, remove this when i implement nix builds for lisp
guile
(self.lisp.sbclWith
- (p: with p; [ asdf alexandria ])) # just enough to build Example.lisp
+ (p: with p; [ alexandria ])) # just enough to build Example.lisp
];
strictDeps = true;
ghcVersion = self.haskell.ghcVersion;
@@ -203,7 +203,6 @@ let
# build an operating system. 'cfg' is the NixOS config
os = cfg: (stable.nixos (_args: cfg)).toplevel;
- os-unstable = cfg: (unstable.nixos (_args: cfg)).toplevel;
# build a docker image
image = stable.dockerTools.buildImage;