summaryrefslogtreecommitdiff
path: root/Biz/Bild.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2023-08-16 14:18:10 -0400
committerBen Sima <ben@bsima.me>2023-08-16 18:25:00 -0400
commit7d7e0c02351303489d5555627337a39b519b536a (patch)
tree794817b6d6046a265a129c910885339058773198 /Biz/Bild.nix
parent30d03210f7ac5b12235760f625bac5ff3aa3f85a (diff)
Get python targets building
I added 'black' to Biz/Lint.hs, but not the others because they rely on dependencies being in the PYTHONPATH to work, so they are only relevant in nix builds and repls. I also made some other tweaks to the python checkPhase and linted all the files. Everything should be building and linting correctly now.
Diffstat (limited to 'Biz/Bild.nix')
-rw-r--r--Biz/Bild.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/Biz/Bild.nix b/Biz/Bild.nix
index dca1b3b..918d6b1 100644
--- a/Biz/Bild.nix
+++ b/Biz/Bild.nix
@@ -146,7 +146,7 @@ rec {
} // { env = ghc; };
env = let
- linters = with nixpkgs.pkgs; [ ormolu hlint deadnix indent ];
+ linters = with nixpkgs.pkgs; [ ormolu hlint deadnix indent black];
in nixpkgs.pkgs.mkShell {
name = "bizdev";
# this should just be dev tools