summaryrefslogtreecommitdiff
path: root/Biz/Bild.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2022-07-18 22:09:58 -0400
committerBen Sima <ben@bsima.me>2022-07-19 09:22:58 -0400
commitbc9e5b0ea863a17537987faa5a72b00efc7767d1 (patch)
treea22df5a00c29f5612a5f6885b9e6bb9a7a56d420 /Biz/Bild.nix
parentf034ad709ba0de5a2e5ec6be47523f595e381d7a (diff)
Upgrade nixpkgs, ghc923
I ended up deleting miso, and consequently all files under Hero/ and Miso/, because I couldn't get miso to build with GHC 9.2. Other things: - Niv has been wrapped by Biz/Bild/Deps.hs, so I can extend it to my liking. - Apply-refact is gone because I couldn't get it to build. - Disabled python stuff.
Diffstat (limited to 'Biz/Bild.nix')
-rw-r--r--Biz/Bild.nix17
1 files changed, 8 insertions, 9 deletions
diff --git a/Biz/Bild.nix b/Biz/Bild.nix
index c007661..e675b68 100644
--- a/Biz/Bild.nix
+++ b/Biz/Bild.nix
@@ -1,8 +1,7 @@
{ nixpkgs ? import ./Bild/Nixpkgs.nix }:
-with import ./Bild/Constants.nix;
-
rec {
+ constants = import ./Bild/Constants.nix;
private = {
inherit nixpkgs;
@@ -21,7 +20,7 @@ rec {
haskellDeps = import ./Bild/Deps/Haskell.nix;
- ghcWith = nixpkgs.haskell.packages.${ghcCompiler}.ghcWithHoogle;
+ ghcWith = nixpkgs.haskell.packages.${constants.ghcCompiler}.ghcWithHoogle;
#mkGhcjsPackageSet = nixpkgs.haskell.packages.${ghcjsCompiler}.ghcWithPackages;
ghcPackageSetFull = private.ghcWith private.haskellDeps;
@@ -140,20 +139,20 @@ rec {
env = nixpkgs.pkgs.mkShell {
name = "bizdev";
+ # this should just be dev tools
buildInputs = with nixpkgs.pkgs; [
- # this should just be dev tools
- haskell.packages.${ghcCompiler}.apply-refact
+ #haskell.packages.${constants.ghcCompiler}.apply-refact
bild
figlet
git
- haskell.packages.${ghcCompiler}.fast-tags
+ haskell.packages.${constants.ghcCompiler}.fast-tags
hlint
lolcat
- niv.niv
nixops
ormolu
- python38Packages.black
- python38Packages.pylint
+ # not using python now, should remove
+ #python38Packages.black
+ #python38Packages.pylint
rustc
sbcl
lispPackages.swank