summaryrefslogtreecommitdiff
path: root/Biz/Bild.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2023-08-22 11:46:08 -0400
committerBen Sima <ben@bsima.me>2023-08-22 11:46:08 -0400
commitc13e829e145daf96ea2be9b4d35fc2a94a1b33bd (patch)
treebeaec3d7c830b5c59561f1a225ea37ac1731c54e /Biz/Bild.nix
parent9eac46cfeddc65938b3cc946629a9c3d93ac35ee (diff)
Replace pylint with ruff
Ruff is like a million times faster, and I mostly ignored pylint's suggestions anyway. I also took this opportunity to move lint tools into a runtime dependency on Lint.hs, which meant adding a wrapper to the Haskell builder, which was easy enough. This paves the way for proper rundeps in bild.
Diffstat (limited to 'Biz/Bild.nix')
-rw-r--r--Biz/Bild.nix6
1 files changed, 0 insertions, 6 deletions
diff --git a/Biz/Bild.nix b/Biz/Bild.nix
index 183e633..9017f17 100644
--- a/Biz/Bild.nix
+++ b/Biz/Bild.nix
@@ -123,18 +123,12 @@ in nixpkgs // { bild = rec {
# this should just be dev tools
buildInputs = with nixpkgs.pkgs; [
bild
- black
ctags
- deadnix
figlet
git
gitlint
- hlint
- indent
lolcat
nixpkgs.haskell.packages.${constants.ghcCompiler}.fast-tags
- ormolu
- shellcheck
wemux
];
shellHook = ''