summaryrefslogtreecommitdiff
path: root/Biz/Bild.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2022-12-28 19:53:55 -0500
committerBen Sima <ben@bsima.me>2022-12-28 19:53:55 -0500
commitc3b955145998d39df39370671585a271ca6f80f0 (patch)
tree33614e03c966d205e2eadaf4dd183f52618afebc /Biz/Bild.nix
parent11e480c4b13808f12bc3f5db2765cebebf1aaf46 (diff)
Get ava GPT chatbot prototype working
Mostly thid required packaging up some deps, but also had to recompile stuff with cuda support.
Diffstat (limited to 'Biz/Bild.nix')
-rw-r--r--Biz/Bild.nix10
1 files changed, 8 insertions, 2 deletions
diff --git a/Biz/Bild.nix b/Biz/Bild.nix
index 47c0ecb..8fe20db 100644
--- a/Biz/Bild.nix
+++ b/Biz/Bild.nix
@@ -146,9 +146,15 @@ rec {
haskell.packages.${constants.ghcCompiler}.fast-tags
hlint
lolcat
- nixops
+ #nixops # fails to build
ormolu
- (python3.withPackages(p: with p; [transformers pytorch]))
+ (private.nixpkgs.python3.withPackages(p:
+ with p; [
+ transformers
+ pytorch
+ private.nixpkgs.python3Packages.bitsandbytes
+ private.nixpkgs.python3Packages.accelerate
+ ]))
shellcheck
wemux
];