summaryrefslogtreecommitdiff
path: root/Biz/Bild.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2023-08-17 17:28:03 -0400
committerBen Sima <ben@bsima.me>2023-08-17 22:43:38 -0400
commitcc6aac612e36da3c9b9b4e47fc16ed512a79f2d9 (patch)
treee32cfb60890c4293465c34d31c5771882b7fcb02 /Biz/Bild.nix
parent204ccb2bcab7b6fa8fb4d8a26e65c591ae075343 (diff)
Nixify rust build
Not getting deps yet but thats okay, I basically need to do a bunch of annoying nix work to get rustPackages into a thing like pythonPackages.
Diffstat (limited to 'Biz/Bild.nix')
-rw-r--r--Biz/Bild.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/Biz/Bild.nix b/Biz/Bild.nix
index 918d6b1..94305bc 100644
--- a/Biz/Bild.nix
+++ b/Biz/Bild.nix
@@ -22,10 +22,12 @@ rec {
haskellDeps = import ./Bild/Deps/Haskell.nix;
+ ghcPackages = nixpkgs.haskellPackages;
ghcWith = nixpkgs.haskell.packages.${constants.ghcCompiler}.ghcWithHoogle;
sbclWith = nixpkgs.lispPackages_new.sbclWithPackages;
+ pythonPackages = nixpkgs.python3Packages;
pythonWith = nixpkgs.python3.withPackages;
ghcPackageSetFull = private.ghcWith private.haskellDeps;
@@ -51,7 +53,6 @@ rec {
(private.ghcWith (hpkgs: with hpkgs; []))
/* disable until nixified builds are complete */
- rustc
# c deps
gcc gdb valgrind argp-standalone SDL
# lisp deps