summaryrefslogtreecommitdiff
path: root/Biz/Bild.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2022-07-29 10:50:41 -0400
committerBen Sima <ben@bsima.me>2022-07-29 10:50:41 -0400
commitd8fe6f7ac54f155fe5a3c33509249a70d0c816c5 (patch)
treeaccdaf7961809b231aab726314dccf0e431463b3 /Biz/Bild.nix
parent347c5d878d064685f4c27f36f38ef20f67996417 (diff)
Implement Guile linking for C builds
In order to write Guile code against C, I need to distiguish between libs and bins, so I did that, then I got the flags that gcc needs from `guile-config` and put them in the args for any C lib build. I tested this with Bessel.c and Bessel.scm (not in this patch, because I don't really want that code in my tree, I'll come up with another way to test it later).
Diffstat (limited to 'Biz/Bild.nix')
-rw-r--r--Biz/Bild.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/Biz/Bild.nix b/Biz/Bild.nix
index da0c6a8..40309a1 100644
--- a/Biz/Bild.nix
+++ b/Biz/Bild.nix
@@ -45,6 +45,11 @@ rec {
src = ../.;
nativeBuildInputs = [ private.ghcPackageSetBild ];
buildInputs = [ nixpkgs.makeWrapper ];
+ propagatedBuildInputs = with nixpkgs; [
+ pkg-config
+ guile_3_0
+ sbcl
+ ];
strictDeps = true;
buildPhase = ''
mkdir -p $out/bin $out/lib/ghc-${private.ghcPackageSetFull.version}