summaryrefslogtreecommitdiff
path: root/Biz/Bild.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2023-08-22 17:15:50 -0400
committerBen Sima <ben@bsima.me>2023-09-19 20:49:54 -0400
commitffe3fd8a719be8d02b03bac6bc8232a7bc9fa692 (patch)
tree64aed59c9c6c22ae607c7379d2667cd71ef8d5d0 /Biz/Bild.nix
parent2bab1000e2cbac69f3cd7d6c437eb63a63843b57 (diff)
Lint faster by grouping files by extension
Previously I would lint every file individually, in serial. This took forever. Now I group the files by extension (by first getting the Namespace) and run each linter on all relevant files at once. This is so much faster its stupid. Also I added formatters back into the dev env because my editor needs them to autoformat.
Diffstat (limited to 'Biz/Bild.nix')
-rw-r--r--Biz/Bild.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/Biz/Bild.nix b/Biz/Bild.nix
index 9017f17..b12b87a 100644
--- a/Biz/Bild.nix
+++ b/Biz/Bild.nix
@@ -123,12 +123,14 @@ in nixpkgs // { bild = rec {
# this should just be dev tools
buildInputs = with nixpkgs.pkgs; [
bild
+ black
ctags
figlet
git
gitlint
lolcat
nixpkgs.haskell.packages.${constants.ghcCompiler}.fast-tags
+ ormolu
wemux
];
shellHook = ''