summaryrefslogtreecommitdiff
path: root/Biz/Bild/Builder.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2023-10-03 22:22:45 -0400
committerBen Sima <ben@bsima.me>2023-10-03 22:22:45 -0400
commit6107f8178e26ada67e5d5ec60501e24528b3db56 (patch)
tree6e7d8bc57231b841545c6e3add46eb51c64a5946 /Biz/Bild/Builder.nix
parent4226cbd8020253b010fb44d395db12efe68e1272 (diff)
Add rundeps feature to bild
This allows me to specify runtime dependencies, not just system or language deps.
Diffstat (limited to 'Biz/Bild/Builder.nix')
-rw-r--r--Biz/Bild/Builder.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/Biz/Bild/Builder.nix b/Biz/Bild/Builder.nix
index 2ed3dd1..959d176 100644
--- a/Biz/Bild/Builder.nix
+++ b/Biz/Bild/Builder.nix
@@ -51,6 +51,12 @@ let
else
lib.attrsets.attrVals target.sysdeps pkgs;
+ rundeps_ =
+ if isEmpty target.rundeps then
+ []
+ else
+ lib.attrsets.attrVals target.rundeps bild.pkgs;
+
CODEROOT = ".";
builders = {
@@ -73,7 +79,7 @@ let
installPhase = ''
install -D ${name} $out/bin/${name}
wrapProgram $out/bin/${name} \
- --prefix PATH : ${lib.makeBinPath sysdeps_}
+ --prefix PATH : ${lib.makeBinPath rundeps_}
'';
};