summaryrefslogtreecommitdiff
path: root/Biz/Bild/Deps.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2021-08-30 20:19:13 -0400
committerBen Sima <ben@bsima.me>2021-11-26 13:47:38 -0500
commit09882de5f3cbfd62d59b9ec94723a90d67555b7d (patch)
tree69f1c1fb85b7706e83be35c93fbd9d63d1b07dec /Biz/Bild/Deps.nix
parent1a5ea40711e35f8b108d10a0667423926d63fd34 (diff)
Update to ghc 8.10.4
This also makes some changes to the build tooling to clean up the environment a bit, and get us closer to 'bild -s'.
Diffstat (limited to 'Biz/Bild/Deps.nix')
-rw-r--r--Biz/Bild/Deps.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/Biz/Bild/Deps.nix b/Biz/Bild/Deps.nix
index 946a834..4f16250 100644
--- a/Biz/Bild/Deps.nix
+++ b/Biz/Bild/Deps.nix
@@ -1,16 +1,16 @@
self: super:
+with import ./Constants.nix;
let
buildCabal = sel: name:
sel.callCabal2nix name super.sources.${name} {};
buildCabalSubdir = sel: {name, src ? super.sources.${name}, subdir ? name}:
sel.callCabal2nix name (src + "/${subdir}") {};
- ghc = "ghc884";
in rec
{
haskell = super.haskell // {
packages = super.haskell.packages // {
- "${ghc}" = super.haskell.packages."${ghc}".override (old: {
+ "${ghcCompiler}" = super.haskell.packages."${ghcCompiler}".override (old: {
overrides = with super.pkgs.haskell.lib; sel: sup:
super.overridePinnedDeps (buildCabal sel) // {
acid-state = dontCheck sup.acid-state; # mac: "too many open files"