summaryrefslogtreecommitdiff
path: root/Biz/Bild/Deps.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2023-08-10 21:11:23 -0400
committerBen Sima <ben@bsima.me>2023-08-16 14:29:43 -0400
commit247678afc7c74c98f64e8d19f67355d128946974 (patch)
tree6bde2696aab9029f67ff6eb136f26b81bcd5a4c4 /Biz/Bild/Deps.nix
parent4e67ef22a7508150798413081bf8a5bb4adab6e5 (diff)
Add llama-cpp and exllama
Diffstat (limited to 'Biz/Bild/Deps.nix')
-rw-r--r--Biz/Bild/Deps.nix8
1 files changed, 5 insertions, 3 deletions
diff --git a/Biz/Bild/Deps.nix b/Biz/Bild/Deps.nix
index 8fc9fc8..da18d89 100644
--- a/Biz/Bild/Deps.nix
+++ b/Biz/Bild/Deps.nix
@@ -33,9 +33,9 @@ in rec
python3 = super.python3.override {
packageOverrides = _: pysuper: with pysuper.pkgs.python3Packages; {
- accelerate = callPackage ./Deps/accelerate.nix {};
- bitsandbytes = callPackage ./Deps/bitsandbytes.nix {};
- lion-pytorch = callPackage ./Deps/lion-pytorch.nix {};
+ exllama = callPackage ./Deps/exllama.nix {
+ cudaPackages = super.pkgs.cudaPackages_11_7;
+ };
};
};
@@ -70,5 +70,7 @@ in rec
];
};
+ llama-cpp = super.callPackage ./Deps/llama-cpp.nix {};
+
nostr-rs-relay = super.callPackage ./Deps/nostr-rs-relay.nix {};
}