summaryrefslogtreecommitdiff
path: root/Biz/Bild/Deps.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2023-08-07 17:57:42 -0400
committerBen Sima <ben@bsima.me>2023-08-07 18:02:13 -0400
commit44b1f8d5bc2ffcb00f56b0096476501e7e0cd458 (patch)
treed005a849d15fe8ef59ed7523b7997d6529020125 /Biz/Bild/Deps.nix
parentedb55ff54b9f81c0942f4120eedd72357d7b3d7c (diff)
Get ava.py running with nixified builds
I had to redo some of my python overrides and crib the bitsandbytes.nix from upstream. Ava is failing because: ValueError: Tokenizer class LlamaTokenizer does not exist or is not currently imported. I think this means I need to update my nixpkgs pin, so I'm gonna snapshot my work in git, do the update, and that might obviate the local bitsandbytes.nix anyway.
Diffstat (limited to 'Biz/Bild/Deps.nix')
-rw-r--r--Biz/Bild/Deps.nix13
1 files changed, 8 insertions, 5 deletions
diff --git a/Biz/Bild/Deps.nix b/Biz/Bild/Deps.nix
index 34be480..20a5e34 100644
--- a/Biz/Bild/Deps.nix
+++ b/Biz/Bild/Deps.nix
@@ -31,13 +31,16 @@ in rec
};
};
- python3Packages = let
- callPackage = super.python3Packages.callPackage;
- in super.python3Packages // rec {
- accelerate = callPackage ./Deps/accelerate.nix {};
- bitsandbytes = callPackage ./Deps/bitsandbytes.nix {};
+ python3 = super.python3.override {
+ packageOverrides = _: pysuper: with pysuper.pkgs.python3Packages; {
+ accelerate = callPackage ./Deps/accelerate.nix {};
+ bitsandbytes = callPackage ./Deps/bitsandbytes.nix {};
+ lion-pytorch = callPackage ./Deps/lion-pytorch.nix {};
+ };
};
+ python3Packages = python3.pkgs;
+
autogen = super.callPackage ./Deps/autogen.nix {};
gnutls = super.gnutls.override { guileBindings = true; };