summaryrefslogtreecommitdiff
path: root/Biz/Bild/Deps.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2022-07-25 09:12:00 -0400
committerBen Sima <ben@bsima.me>2022-07-25 09:12:00 -0400
commit703f950a6316486bd626cb39e6cbe1484c5d2019 (patch)
tree01869e5ae2a034d8342dbd0a49b665ffbabe19f7 /Biz/Bild/Deps.nix
parentf91d101dffb51c8eb207914833d1a5241149ae7b (diff)
Remove GHCJS support completely
I don't care about ghcjs anymore, the most javascript I want to do is jQuery.
Diffstat (limited to 'Biz/Bild/Deps.nix')
-rw-r--r--Biz/Bild/Deps.nix26
1 files changed, 0 insertions, 26 deletions
diff --git a/Biz/Bild/Deps.nix b/Biz/Bild/Deps.nix
index 84639b5..79f7ac3 100644
--- a/Biz/Bild/Deps.nix
+++ b/Biz/Bild/Deps.nix
@@ -18,7 +18,6 @@ in rec
envy = doJailbreak sup.envy;
fast-tags = sup.fast-tags.overrideAttrs (old: old // { patches = []; });
generic-data = dontCheck sup.generic-data; # https://github.com/Lysxia/generic-data/issues/56
- ghcjs-base = null; # otherwise ghc tries to build this via overridePinnedDeps
readable = doJailbreak sup.readable; # why is this even being built?
servant-auth = doJailbreak (buildCabalSubdir sel {name = "servant-auth"; subdir = "servant-auth/servant-auth";});
servant-server = doJailbreak sup.servant-server;
@@ -29,31 +28,6 @@ in rec
wai-middleware-metrics = dontCheck sup.wai-middleware-metrics;
};
});
- #ghcjs86 = pkgs.haskell.packages.ghcjs86.override (old: {
- # overrides = with pkgs.haskell.lib; sel: sup:
- # super.overridePinnedDeps (buildCabal sel) // {
- # Glob = dontCheck sup.Glob;
- # QuickCheck = dontCheck sup.QuickCheck;
- # aeson = dontCheck sup.aeson;
- # base-compat-batteries = dontCheck sup.base-compat-batteries;
- # clay = dontCheck sup.clay;
- # comonad = dontCheck sup.comonad;
- # ghcjs-base = dontCheck (buildCabal sel "ghcjs-base");
- # jsaddle-warp = dontCheck (buildCabalSubdir sel {
- # name = "jsaddle-warp";
- # src = pkgs.sources.jsaddle;
- # });
- # http-types = dontCheck sup.http-types;
- # network-uri= dontCheck sup.network-uri;
- # scientific = dontCheck sup.scientific; # takes forever
- # servant = dontCheck sup.servant;
- # servant-auth = buildCabalSubdir sel "servant-auth";
- # tasty-quickcheck = dontCheck sup.tasty-quickcheck;
- # temporary = dontCheck sup.temporary;
- # time-compat = dontCheck sup.time-compat;
- # vector = dontCheck sup.vector;
- # };
- #});
};
};