summaryrefslogtreecommitdiff
path: root/Biz/Bild/Deps.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2022-12-28 19:53:55 -0500
committerBen Sima <ben@bsima.me>2022-12-28 19:53:55 -0500
commitc3b955145998d39df39370671585a271ca6f80f0 (patch)
tree33614e03c966d205e2eadaf4dd183f52618afebc /Biz/Bild/Deps.nix
parent11e480c4b13808f12bc3f5db2765cebebf1aaf46 (diff)
Get ava GPT chatbot prototype working
Mostly thid required packaging up some deps, but also had to recompile stuff with cuda support.
Diffstat (limited to 'Biz/Bild/Deps.nix')
-rw-r--r--Biz/Bild/Deps.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/Biz/Bild/Deps.nix b/Biz/Bild/Deps.nix
index a6e31a4..952a294 100644
--- a/Biz/Bild/Deps.nix
+++ b/Biz/Bild/Deps.nix
@@ -31,6 +31,13 @@ in rec
};
};
+ python3Packages = let
+ callPackage = super.python3Packages.callPackage;
+ in super.python3Packages // rec {
+ accelerate = callPackage ./Deps/accelerate.nix {};
+ bitsandbytes = callPackage ./Deps/bitsandbytes.nix {};
+ };
+
autogen = super.autogen.overrideAttrs (old: old // {
buildInputs = super.lib.lists.remove super.guile old.buildInputs ++ [super.guile_2_0];
});