summaryrefslogtreecommitdiff
path: root/Biz/Bild/Deps.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2021-06-26 06:21:56 -0400
committerBen Sima <ben@bsima.me>2021-11-26 13:47:36 -0500
commitca1db1b637cdc8b40eb1918fde7c5ab1b89eeb8d (patch)
treebbefb1d3a5a07fda65caf87d85a01a4de8b25b86 /Biz/Bild/Deps.nix
parentaf28ed31aa36ef0de0a8f65bba9fe066e129c57b (diff)
Begin packaging guix for nix
Diffstat (limited to 'Biz/Bild/Deps.nix')
-rw-r--r--Biz/Bild/Deps.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/Biz/Bild/Deps.nix b/Biz/Bild/Deps.nix
index 790011c..946a834 100644
--- a/Biz/Bild/Deps.nix
+++ b/Biz/Bild/Deps.nix
@@ -57,4 +57,25 @@ in rec
guile-opengl = super.callPackage ./Deps/guile-opengl.nix {};
# The libfive build is broken...
#inspekt3d = super.callPackage ./Deps/inspekt3d.nix {};
+ guix = super.pkgs.stdenv.mkDerivation rec {
+ pname = "guix";
+ name = "${pname}-${version}";
+ version = super.sources.guix.version;
+ src = super.sources.guix;
+ buildInputs = with super.pkgs; [
+ guile
+ # guile-gcrypt
+ # guile-sql
+ # guile-zlib
+ # guile-lzlib
+ # guile-avahi
+ # guile-git
+ # guile-json
+ gnutls
+ gnumake
+ sqlite
+ libgcrypt
+ gcc
+ ];
+ };
}