summaryrefslogtreecommitdiff
path: root/Biz/Bild/Deps/accelerate.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-04-01 13:30:45 -0400
committerBen Sima <ben@bsima.me>2024-04-01 13:30:45 -0400
commitdb373a8c727cad91d375b40a6c70b11ed73bdafb (patch)
treea7ed24e98242b6e38f44cb0c9884718d248cc613 /Biz/Bild/Deps/accelerate.nix
parent5c8ef1bf4dff4fc7c6e66a57673a81477bcc850a (diff)
Add nixfmt to Lint.hs
nixfmt is the soon-to-be official formatter for Nix code, as per the NixOS GitHub group. So I figure I should just adopt it without worrying too much about the specifics of the formatting. I just formatted everything in one go, hence the huge diff, oh well.
Diffstat (limited to 'Biz/Bild/Deps/accelerate.nix')
-rw-r--r--Biz/Bild/Deps/accelerate.nix12
1 files changed, 2 insertions, 10 deletions
diff --git a/Biz/Bild/Deps/accelerate.nix b/Biz/Bild/Deps/accelerate.nix
index 5d00f14..be1d2fd 100644
--- a/Biz/Bild/Deps/accelerate.nix
+++ b/Biz/Bild/Deps/accelerate.nix
@@ -1,18 +1,10 @@
-{ fetchFromGitHub
-, buildPythonPackage
-, numpy
-, packaging
-, psutil
-, pyyaml
-, torch
+{ fetchFromGitHub, buildPythonPackage, numpy, packaging, psutil, pyyaml, torch
}:
buildPythonPackage rec {
name = "accelerate";
version = "0.15.0";
- propagatedBuildInputs = [
- numpy packaging psutil pyyaml torch
- ];
+ propagatedBuildInputs = [ numpy packaging psutil pyyaml torch ];
doCheck = false;
src = fetchFromGitHub {
owner = "huggingface";