summaryrefslogtreecommitdiff
path: root/Biz/Bild/Deps/autogen.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-12-21 10:40:06 -0400
committerBen Sima <ben@bsima.me>2024-12-21 09:40:06 -0500
commit79390d4eea20ca15fd8e088345528f31ed5fad1e (patch)
treef08b71ffddead23484fd6df9e1aff54d20f12768 /Biz/Bild/Deps/autogen.nix
parent18956baad9cde85bc55bd0113092e51786d9e1ee (diff)
Upgrade to nixos-24.05
I think this is the only "supported" nixos version now. But in any case scipy seemed to be broken on the older version, and I couldn't build my code that uses llm. Also, this allows me to get rid of the bild.os-unstable thing for Beryllium, which was just a sitting timebomb of breaking stuff. There are a lot of changes here because ruff updated to the very latest, and it changed some minor lint things. Also with the new nixos I get a proper cgit module, and some other breaking changes needed fixing.
Diffstat (limited to 'Biz/Bild/Deps/autogen.nix')
-rw-r--r--Biz/Bild/Deps/autogen.nix107
1 files changed, 0 insertions, 107 deletions
diff --git a/Biz/Bild/Deps/autogen.nix b/Biz/Bild/Deps/autogen.nix
deleted file mode 100644
index fc95b14..0000000
--- a/Biz/Bild/Deps/autogen.nix
+++ /dev/null
@@ -1,107 +0,0 @@
-# From: https://github.com/NixOS/nixpkgs/pull/139361
-{ lib, stdenv, buildPackages, fetchurl, fetchpatch, autoreconfHook, which
-, pkg-config, perl, guile, libxml2 }:
-
-stdenv.mkDerivation rec {
- pname = "autogen";
- version = "5.18.16";
-
- src = fetchurl {
- url = "mirror://gnu/autogen/rel${version}/autogen-${version}.tar.xz";
- sha256 = "16mlbdys8q4ckxlvxyhwkdnh1ay9f6g0cyp1kylkpalgnik398gq";
- };
-
- patches = let
- dp = { ver ? "1%255.18.16-4", pname, name ? (pname + ".diff"), sha256 }:
- fetchurl {
- url = "https://salsa.debian.org/debian/autogen/-/raw/debian/${ver}"
- + "/debian/patches/${pname}.diff?inline=false";
- inherit name sha256;
- };
- in [
- (dp {
- pname = "20_no_Werror";
- sha256 = "08z4s2ifiqyaacjpd9pzr59w8m4j3548kkaq1bwvp2gjn29m680x";
- })
- (dp {
- pname = "30_ag_macros.m4_syntax_error";
- sha256 = "1z8vmbwbkz3505wd33i2xx91mlf8rwsa7klndq37nw821skxwyh3";
- })
- (dp {
- pname = "31_allow_overriding_AGexe_for_crossbuild";
- sha256 = "0h9wkc9bqb509knh8mymi43hg6n6sxg2lixvjlchcx7z0j7p8xkf";
- })
- # Next upstream release will contain guile-3 support. We apply non-invasive
- # patch meanwhile.
- (fetchpatch {
- name = "guile-3.patch";
- url =
- "https://gitweb.gentoo.org/repo/gentoo.git/plain/sys-devel/autogen/files/autogen-5.18.16-guile-3.patch?id=43bcc61c56a5a7de0eaf806efec7d8c0e4c01ae7";
- sha256 = "18d7y1f6164dm1wlh7rzbacfygiwrmbc35a7qqsbdawpkhydm5lr";
- })
- ];
-
- outputs = [ "bin" "dev" "lib" "out" "man" "info" ];
-
- nativeBuildInputs = [
- which
- pkg-config
- perl
- autoreconfHook # patches applied
- ] ++ lib.optionals (stdenv.hostPlatform != stdenv.buildPlatform) [
- # autogen needs a build autogen when cross-compiling
- buildPackages.buildPackages.autogen
- buildPackages.texinfo
- ];
- buildInputs = [ guile libxml2 ];
-
- preConfigure = ''
- export MAN_PAGE_DATE=$(date '+%Y-%m-%d' -d "@$SOURCE_DATE_EPOCH")
- '';
-
- configureFlags = [
- # Make sure to use a static value for the timeout. If we do not set a value
- # here autogen will select one based on the execution time of the configure
- # phase which is not really reproducible.
- #
- # If you are curious about the number 78, it has been cargo-culted from
- # Debian: https://salsa.debian.org/debian/autogen/-/blob/master/debian/rules#L21
- "--enable-timeout=78"
- ] ++ (lib.optionals (stdenv.hostPlatform != stdenv.buildPlatform) [
- "--with-libxml2=${libxml2.dev}"
- "--with-libxml2-cflags=-I${libxml2.dev}/include/libxml2"
- # the configure check for regcomp wants to run a host program
- "libopts_cv_with_libregex=yes"
- #"MAKEINFO=${buildPackages.texinfo}/bin/makeinfo"
- ])
- # See: https://sourceforge.net/p/autogen/bugs/187/
- ++ lib.optionals stdenv.isDarwin [ "ac_cv_func_utimensat=no" ];
-
- #doCheck = true; # not reliable
-
- postInstall = ''
- mkdir -p $dev/bin
- mv $bin/bin/autoopts-config $dev/bin
-
- for f in $lib/lib/autogen/tpl-config.tlib $out/share/autogen/tpl-config.tlib; do
- sed -e "s|$dev/include|/no-such-autogen-include-path|" -i $f
- sed -e "s|$bin/bin|/no-such-autogen-bin-path|" -i $f
- sed -e "s|$lib/lib|/no-such-autogen-lib-path|" -i $f
- done
-
- '' + lib.optionalString (!stdenv.hostPlatform.isDarwin) ''
- # remove /build/** from RPATHs
- for f in "$bin"/bin/*; do
- local nrp="$(patchelf --print-rpath "$f" | sed -E 's@(:|^)/build/[^:]*:@\1@g')"
- patchelf --set-rpath "$nrp" "$f"
- done
- '';
-
- meta = with lib; {
- description = "Automated text and program generation tool";
- license = with licenses; [ gpl3Plus lgpl3Plus ];
- homepage = "https://www.gnu.org/software/autogen/";
- platforms = platforms.all;
- maintainers = [ ];
- };
-}