summaryrefslogtreecommitdiff
path: root/Biz/Bild/Deps/guile-opengl.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-11-15 14:55:37 -0500
committerBen Sima <ben@bsima.me>2024-12-21 10:06:49 -0500
commit6513755670892983db88a6633b8c1ea6019c03d1 (patch)
tree44e9eccdb7a3a74ab7e96a8fee7572dd6a78dc73 /Biz/Bild/Deps/guile-opengl.nix
parentae7b7e0186b5f2e0dcd4d5fac0a71fa264caedc2 (diff)
Re-namespace some stuff to Omni
I was getting confused about what is a product and what is internal infrastructure; I think it is good to keep those things separate. So I moved a bunch of stuff to an Omni namespace, actually most stuff went there. Only things that are explicitly external products are still in the Biz namespace.
Diffstat (limited to 'Biz/Bild/Deps/guile-opengl.nix')
-rw-r--r--Biz/Bild/Deps/guile-opengl.nix32
1 files changed, 0 insertions, 32 deletions
diff --git a/Biz/Bild/Deps/guile-opengl.nix b/Biz/Bild/Deps/guile-opengl.nix
deleted file mode 100644
index af01082..0000000
--- a/Biz/Bild/Deps/guile-opengl.nix
+++ /dev/null
@@ -1,32 +0,0 @@
-{ stdenv, lib, fetchurl, pkg-config, guile, libGL, libGLU, freeglut }:
-
-let
- name = "guile-opengl-${version}";
- version = "0.1.0";
-in stdenv.mkDerivation {
- inherit name;
-
- src = fetchurl {
- url = "mirror://gnu/guile-opengl/${name}.tar.gz";
- sha256 = "13qfx4xh8baryxqrv986l848ygd0piqwm6s2s90pxk9c0m9vklim";
- };
-
- patchPhase = ''
- substituteInPlace glx/runtime.scm \
- --replace '(dynamic-link "libGL")' '(dynamic-link "${libGL}/lib/libGL.so")'
- substituteInPlace glu/runtime.scm \
- --replace '(dynamic-link "libGLU")' '(dynamic-link "${libGLU}/lib/libGLU.so")'
- substituteInPlace glut/runtime.scm \
- --replace '(dynamic-link "libglut")' '(dynamic-link "${freeglut}/lib/libglut.so")'
- '';
-
- nativeBuildInputs = [ pkg-config guile libGL libGLU freeglut ];
-
- meta = with lib; {
- description = "Guile bindings for the OpenGL graphics API";
- homepage = "https://www.gnu.org/software/guile-opengl/";
- license = licenses.gpl3Plus;
- maintainers = with maintainers; [ vyp ];
- platforms = platforms.all;
- };
-}