summaryrefslogtreecommitdiff
path: root/Biz/Bild/Deps/inspekt3d.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-12-21 10:40:06 -0400
committerBen Sima <ben@bsima.me>2024-12-21 09:40:06 -0500
commit79390d4eea20ca15fd8e088345528f31ed5fad1e (patch)
treef08b71ffddead23484fd6df9e1aff54d20f12768 /Biz/Bild/Deps/inspekt3d.nix
parent18956baad9cde85bc55bd0113092e51786d9e1ee (diff)
Upgrade to nixos-24.05
I think this is the only "supported" nixos version now. But in any case scipy seemed to be broken on the older version, and I couldn't build my code that uses llm. Also, this allows me to get rid of the bild.os-unstable thing for Beryllium, which was just a sitting timebomb of breaking stuff. There are a lot of changes here because ruff updated to the very latest, and it changed some minor lint things. Also with the new nixos I get a proper cgit module, and some other breaking changes needed fixing.
Diffstat (limited to 'Biz/Bild/Deps/inspekt3d.nix')
-rw-r--r--Biz/Bild/Deps/inspekt3d.nix5
1 files changed, 2 insertions, 3 deletions
diff --git a/Biz/Bild/Deps/inspekt3d.nix b/Biz/Bild/Deps/inspekt3d.nix
index d1cf60e..a9dac3d 100644
--- a/Biz/Bild/Deps/inspekt3d.nix
+++ b/Biz/Bild/Deps/inspekt3d.nix
@@ -1,4 +1,4 @@
-{ stdenv, lib, autoreconfHook, pkgconfig, guile, guile-opengl, mesa
+{ stdenv, lib, autoreconfHook, pkg-config, guile, guile-opengl, mesa
, glibcLocales, libfive, sources }:
stdenv.mkDerivation {
@@ -7,7 +7,7 @@ stdenv.mkDerivation {
src = sources.inspekt3d;
version = "unstable-2018-10-17";
- nativeBuildInputs = [ pkgconfig autoreconfHook ];
+ nativeBuildInputs = [ pkg-config autoreconfHook ];
buildInputs = [ guile glibcLocales mesa ];
propagatedBuildInputs = [ guile-opengl libfive ];
@@ -28,4 +28,3 @@ stdenv.mkDerivation {
platforms = platforms.all;
};
}
-