summaryrefslogtreecommitdiff
path: root/Biz/Bild/Deps/lion-pytorch.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-11-15 14:55:37 -0500
committerBen Sima <ben@bsima.me>2024-12-21 10:06:49 -0500
commit6513755670892983db88a6633b8c1ea6019c03d1 (patch)
tree44e9eccdb7a3a74ab7e96a8fee7572dd6a78dc73 /Biz/Bild/Deps/lion-pytorch.nix
parentae7b7e0186b5f2e0dcd4d5fac0a71fa264caedc2 (diff)
Re-namespace some stuff to Omni
I was getting confused about what is a product and what is internal infrastructure; I think it is good to keep those things separate. So I moved a bunch of stuff to an Omni namespace, actually most stuff went there. Only things that are explicitly external products are still in the Biz namespace.
Diffstat (limited to 'Biz/Bild/Deps/lion-pytorch.nix')
-rw-r--r--Biz/Bild/Deps/lion-pytorch.nix27
1 files changed, 0 insertions, 27 deletions
diff --git a/Biz/Bild/Deps/lion-pytorch.nix b/Biz/Bild/Deps/lion-pytorch.nix
deleted file mode 100644
index 7b06e78..0000000
--- a/Biz/Bild/Deps/lion-pytorch.nix
+++ /dev/null
@@ -1,27 +0,0 @@
-{ lib, buildPythonPackage, pythonOlder, fetchFromGitHub, torch }:
-
-buildPythonPackage rec {
- pname = "lion-pytorch";
- version = "0.1.2";
- format = "setuptools";
- disabled = pythonOlder "3.6";
-
- src = fetchFromGitHub {
- owner = "lucidrains";
- repo = "lion-pytorch";
- rev = "refs/tags/${version}";
- hash = "sha256-9hdpRJvCpv3PeC7f0IXpHt6i+e6LiT0QUl5jeDGelQE=";
- };
-
- propagatedBuildInputs = [ torch ];
-
- pythonImportsCheck = [ "lion_pytorch" ];
- doCheck = false; # no tests currently
-
- meta = with lib; {
- description = "Optimizer tuned by Google Brain using genetic algorithms";
- homepage = "https://github.com/lucidrains/lion-pytorch";
- license = licenses.mit;
- maintainers = with maintainers; [ bcdarwin ];
- };
-}