summaryrefslogtreecommitdiff
path: root/Biz/Bild/Deps/llm-ollama.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-11-15 14:55:37 -0500
committerBen Sima <ben@bsima.me>2024-12-21 10:06:49 -0500
commit6513755670892983db88a6633b8c1ea6019c03d1 (patch)
tree44e9eccdb7a3a74ab7e96a8fee7572dd6a78dc73 /Biz/Bild/Deps/llm-ollama.nix
parentae7b7e0186b5f2e0dcd4d5fac0a71fa264caedc2 (diff)
Re-namespace some stuff to Omni
I was getting confused about what is a product and what is internal infrastructure; I think it is good to keep those things separate. So I moved a bunch of stuff to an Omni namespace, actually most stuff went there. Only things that are explicitly external products are still in the Biz namespace.
Diffstat (limited to 'Biz/Bild/Deps/llm-ollama.nix')
-rw-r--r--Biz/Bild/Deps/llm-ollama.nix40
1 files changed, 0 insertions, 40 deletions
diff --git a/Biz/Bild/Deps/llm-ollama.nix b/Biz/Bild/Deps/llm-ollama.nix
deleted file mode 100644
index e2b6a66..0000000
--- a/Biz/Bild/Deps/llm-ollama.nix
+++ /dev/null
@@ -1,40 +0,0 @@
-{ buildPythonPackage, fetchFromGitHub, lib, llm, ollama, pytestCheckHook
-, setuptools, pythonOlder, }:
-buildPythonPackage rec {
- pname = "llm-ollama";
- version = "0.3.0";
- pyproject = true;
-
- disabled = pythonOlder "3.8";
-
- src = fetchFromGitHub {
- owner = "taketwo";
- repo = pname;
- rev = "refs/tags/${version}";
- hash = "sha256-Ar0Ux8BNGY0i764CEk7+48J6jnndlRIIMPZ9tFpXiy4=";
- };
-
- nativeBuildInputs = [ setuptools ];
-
- buildInputs = [ llm ollama ];
-
- propagatedBuildInputs = [ ollama ];
-
- disabledTests = [
- # wants to mkdir in the /homeless-shelter
- "test_registered_models"
- ];
-
- nativeCheckInputs = [ pytestCheckHook ];
-
- pythonImportsCheck = [ "llm_ollama" ];
-
- meta = with lib; {
- homepage = "https://github.com/taketwo/llm-ollama";
- description =
- "LLM plugin providing access to local Ollama models usting HTTP API";
- changelog = "https://github.com/taketwo/llm-ollama/releases/tag/${version}";
- license = licenses.asl20;
- maintainers = with maintainers; [ bsima ];
- };
-}