summaryrefslogtreecommitdiff
path: root/Biz/Bild/Deps/llm-sentence-transformers.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-11-15 14:55:37 -0500
committerBen Sima <ben@bsima.me>2024-12-21 10:06:49 -0500
commit6513755670892983db88a6633b8c1ea6019c03d1 (patch)
tree44e9eccdb7a3a74ab7e96a8fee7572dd6a78dc73 /Biz/Bild/Deps/llm-sentence-transformers.nix
parentae7b7e0186b5f2e0dcd4d5fac0a71fa264caedc2 (diff)
Re-namespace some stuff to Omni
I was getting confused about what is a product and what is internal infrastructure; I think it is good to keep those things separate. So I moved a bunch of stuff to an Omni namespace, actually most stuff went there. Only things that are explicitly external products are still in the Biz namespace.
Diffstat (limited to 'Biz/Bild/Deps/llm-sentence-transformers.nix')
-rw-r--r--Biz/Bild/Deps/llm-sentence-transformers.nix42
1 files changed, 0 insertions, 42 deletions
diff --git a/Biz/Bild/Deps/llm-sentence-transformers.nix b/Biz/Bild/Deps/llm-sentence-transformers.nix
deleted file mode 100644
index 4d63c83..0000000
--- a/Biz/Bild/Deps/llm-sentence-transformers.nix
+++ /dev/null
@@ -1,42 +0,0 @@
-{ buildPythonPackage, fetchFromGitHub, lib, llm, sentence-transformers
-, pytestCheckHook, setuptools, pythonOlder, }:
-buildPythonPackage rec {
- pname = "llm-sentence-transformers";
- version = "0.2";
- pyproject = true;
-
- disabled = pythonOlder "3.8";
-
- src = fetchFromGitHub {
- owner = "simonw";
- repo = pname;
- rev = "refs/tags/${version}";
- hash = "sha256-1NlKPWekdVLrNkIMWXLCRWn54RlAEuEDWMCDnQHNkBc=";
- };
-
- nativeBuildInputs = [ setuptools ];
-
- buildInputs = [ llm sentence-transformers ];
-
- propagatedBuildInputs = [ sentence-transformers ];
-
- # fails because of some pydantic warnings
- doCheck = false;
- disabledTests = [
- # wants to mkdir in the /homeless-shelter
- "test_sentence_transformers"
- ];
-
- nativeCheckInputs = [ pytestCheckHook ];
-
- pythonImportsCheck = [ "llm_sentence_transformers" ];
-
- meta = with lib; {
- homepage = "https://github.com/taketwo/llm-sentence-transformers";
- description = "LLM plugin for embeddings using sentence-transformers";
- changelog =
- "https://github.com/taketwo/llm-sentence-transformers/releases/tag/${version}";
- license = licenses.asl20;
- maintainers = with maintainers; [ bsima ];
- };
-}