summaryrefslogtreecommitdiff
path: root/Biz/Bild/Functions.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-11-15 14:55:37 -0500
committerBen Sima <ben@bsima.me>2024-12-21 10:06:49 -0500
commit6513755670892983db88a6633b8c1ea6019c03d1 (patch)
tree44e9eccdb7a3a74ab7e96a8fee7572dd6a78dc73 /Biz/Bild/Functions.nix
parentae7b7e0186b5f2e0dcd4d5fac0a71fa264caedc2 (diff)
Re-namespace some stuff to Omni
I was getting confused about what is a product and what is internal infrastructure; I think it is good to keep those things separate. So I moved a bunch of stuff to an Omni namespace, actually most stuff went there. Only things that are explicitly external products are still in the Biz namespace.
Diffstat (limited to 'Biz/Bild/Functions.nix')
-rw-r--r--Biz/Bild/Functions.nix33
1 files changed, 0 insertions, 33 deletions
diff --git a/Biz/Bild/Functions.nix b/Biz/Bild/Functions.nix
deleted file mode 100644
index 8b87f86..0000000
--- a/Biz/Bild/Functions.nix
+++ /dev/null
@@ -1,33 +0,0 @@
-_: super: {
- # Given a generic `builder`, will generate an attrset for all the packages
- # pinned by `deps` with `builder` applied to the package. This attrset can
- # then be merged with the rest of the packages in the set as part of an
- # overlay or overrides.
- overridePinnedDeps = builder:
- super.lib.genAttrs (builtins.attrNames super.sources) builder;
-
- # Modifies a derivation with our source and version, keeping super build
- # rules. This will fail if build steps have changed, or if no build
- # rules are available upstream.
- overrideSource = depName:
- if super ? "${depName}" && super.${depName} ? overrideAttrs then
- super.${depName}.overrideAttrs (attrs:
- attrs // rec {
- version =
- super.sources.${depName}.version or super.sources.${depName}.rev;
- src = super.sources.${depName};
- })
- else
- null;
-
- # Simply override the 'src' attr on a drv. This is meant to be a simpler
- # alternative to 'overrideSource' above. In an overlay, use it like:
- # mypkg = super.overrideSrc super.mypkg super.sources.mypkg;
- overrideSrc = dep: src:
- dep.overrideAttrs (attrs:
- attrs // {
- version = src.version or src.rev;
- src = src;
- });
-}
-