summaryrefslogtreecommitdiff
path: root/Biz/Bild/Python.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-04-08 16:02:03 -0400
committerBen Sima <ben@bsima.me>2024-04-10 19:56:46 -0400
commitaa5f12a5a2365a35f17becc66cf7a67fa86a4440 (patch)
treee43c059973558ea0b1687525e00789c353491460 /Biz/Bild/Python.nix
parent544d75a47e85d2b334267a43ba065bb69538ad75 (diff)
Reorganize and update nixpkgs upstreams
This patch does a few things: 1. Switches from nixpkgs-unstable to nixos-unstable{,-small}, simply because nixpkgs-unstable is not in cache.nixos.org, but nixos-unstable is, and -small is the same but requires all tests to pass. So we should prefer nixos-unstable-small, whenever possible. 2. Reorganizes the nixpkgs import code such that Nixpkgs.nix returns an attrset of all the nixpkgs that I want to use, rather than putting other nixpkgs branches into the main one as an overlay. This is much simpler and explicit, but it meant I had to change a lot of usages throughtout the nix codebase. 3. As a consequence of 2, moves the overlays into separate files so they can be re-used across nixpkgs branches.
Diffstat (limited to 'Biz/Bild/Python.nix')
-rw-r--r--Biz/Bild/Python.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/Biz/Bild/Python.nix b/Biz/Bild/Python.nix
new file mode 100644
index 0000000..51f35f1
--- /dev/null
+++ b/Biz/Bild/Python.nix
@@ -0,0 +1,23 @@
+_self: super: {
+ python3 = super.python3.override {
+ packageOverrides = _pyself: pysuper:
+ with pysuper.pkgs.python3Packages;
+ let dontCheck = p: p.overridePythonAttrs (_: { doCheck = false; });
+ in {
+ exllama = callPackage ./Deps/exllama.nix {
+ cudaPackages = super.pkgs.cudaPackages_11_7;
+ };
+ exllamav2 = callPackage ./Deps/exllamav2.nix {
+ cudaPackages = super.pkgs.cudaPackages_11_7;
+ };
+ interegular = callPackage ./Deps/interegular.nix { };
+ mypy = dontCheck pysuper.mypy;
+ outlines = callPackage ./Deps/outlines.nix { };
+ perscache = callPackage ./Deps/perscache.nix { };
+ safetensors = super.nixos-23_11.python310Packages.safetensors.override {
+ buildPythonPackage = pysuper.pkgs.python3Packages.buildPythonPackage;
+ };
+ tokenizers = dontCheck pysuper.tokenizers;
+ };
+ };
+}