summaryrefslogtreecommitdiff
path: root/Biz/Bild/Rules.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2020-11-24 12:08:13 -0500
committerBen Sima <ben@bsima.me>2020-11-24 12:08:13 -0500
commit1a47cf6ff0cbe6cc80e3497a68343b8ecb9228c1 (patch)
treea29ea5743893fe2ec356da9cc198cb8957fe6d5e /Biz/Bild/Rules.nix
parent8e256e46bca4b3f04c6379a8ff98d3c5cb7a3683 (diff)
Add inspekt3d to guile deps, and reorganize
I reorganized in order to debug a problem with the nix overlays. I think having small, focused overlayes is more understandable than one overlay that references itself via `rec`. Also the error traces are easier to follow with smaller overlays.
Diffstat (limited to 'Biz/Bild/Rules.nix')
-rw-r--r--Biz/Bild/Rules.nix15
1 files changed, 11 insertions, 4 deletions
diff --git a/Biz/Bild/Rules.nix b/Biz/Bild/Rules.nix
index 2141fbf..1868313 100644
--- a/Biz/Bild/Rules.nix
+++ b/Biz/Bild/Rules.nix
@@ -17,7 +17,7 @@ let
subset = a: b: builtins.all
(x: builtins.elem x b) a;
- allDeps = import ./Deps.nix;
+ haskellDeps = import ./Deps/Haskell.nix;
# gather data needed for compiling by analyzing the main module
analyze = main: rec {
@@ -43,11 +43,11 @@ let
};
mkGhc = compiler: (deps: compiler (hp:
- if (subset deps allDeps)
+ if (subset deps haskellDeps)
then depsToPackageSet hp deps
else throw ''
missing from nix/haskell-deps.nix:
- ${toString (lib.lists.subtractLists allDeps deps)}
+ ${toString (lib.lists.subtractLists haskellDeps deps)}
''));
ghc_ = mkGhc pkgs.haskell.packages.ghc865.ghcWithHoogle;
@@ -104,7 +104,8 @@ in {
env = mkShell {
name = "bizdev";
buildInputs = [
- (ghc_ allDeps)
+ # haskell deps
+ (ghc_ haskellDeps)
# ghcjs doesn't need everything, and many things fail to build
(ghcjs_ [
"aeson"
@@ -119,6 +120,12 @@ in {
"ghcjs-base"
])
+ # scheme deps
+ nixpkgs.guile
+ nixpkgs.inspekt3d
+ nixpkgs.libfive
+
+ # tools
nixpkgs.cmark
nixpkgs.figlet
nixpkgs.hlint