summaryrefslogtreecommitdiff
path: root/Biz/Bild/Rules.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2020-11-12 17:13:39 -0800
committerBen Sima <ben@bsima.me>2020-11-12 17:21:13 -0800
commit890e44ebcc11c48f7347aa60748a84c48261aa5e (patch)
tree894e30ce7a0c81ef3968c04f82d068a65c15b0f5 /Biz/Bild/Rules.nix
parent19f5402bec9f6346463b83536cc22d7f4525bc18 (diff)
Get Biz.Dev setup again
Also correctly renamed the files (didn't work the first time thanks to the macOS filesystem) and moved the default build.os settings to a OsBase.nix file to be used via imports.
Diffstat (limited to 'Biz/Bild/Rules.nix')
-rw-r--r--Biz/Bild/Rules.nix24
1 files changed, 1 insertions, 23 deletions
diff --git a/Biz/Bild/Rules.nix b/Biz/Bild/Rules.nix
index 9fea5df..e6a6979 100644
--- a/Biz/Bild/Rules.nix
+++ b/Biz/Bild/Rules.nix
@@ -128,27 +128,5 @@ in {
shellHook = ". ${./ShellHook.sh}";
};
- os = cfg: (nixos (args: lib.attrsets.recursiveUpdate cfg {
- boot.cleanTmpDir = true;
- networking.firewall.allowPing = true;
- nix.binaryCaches = [ "https://cache.nixos.org" ];
- nix.gc.automatic = true;
- nix.gc.dates = "Sunday 02:15";
- nix.optimise.automatic = true;
- nix.optimise.dates = [ "Sunday 02:30" ];
- nixpkgs.overlays = overlays;
- programs.mosh.enable = true;
- programs.mosh.withUtempter = true;
- security.acme.email = "ben@bsima.me";
- security.acme.acceptTerms = true;
- security.sudo.wheelNeedsPassword = false;
- services.clamav.daemon.enable = true; # security
- services.clamav.updater.enable = true; # security
- services.fail2ban.enable = true; # security
- services.openssh.enable = true;
- services.openssh.openFirewall = true;
- services.openssh.forwardX11 = true;
- services.openssh.passwordAuthentication = false;
- system.autoUpgrade.enable = false; # 'true' breaks our nixpkgs pin
- })).toplevel;
+ os = cfg: (nixos (args: cfg)).toplevel;
}