summaryrefslogtreecommitdiff
path: root/Biz/Bot.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-11-15 14:55:37 -0500
committerBen Sima <ben@bsima.me>2024-12-21 10:06:49 -0500
commit6513755670892983db88a6633b8c1ea6019c03d1 (patch)
tree44e9eccdb7a3a74ab7e96a8fee7572dd6a78dc73 /Biz/Bot.nix
parentae7b7e0186b5f2e0dcd4d5fac0a71fa264caedc2 (diff)
Re-namespace some stuff to Omni
I was getting confused about what is a product and what is internal infrastructure; I think it is good to keep those things separate. So I moved a bunch of stuff to an Omni namespace, actually most stuff went there. Only things that are explicitly external products are still in the Biz namespace.
Diffstat (limited to 'Biz/Bot.nix')
-rw-r--r--Biz/Bot.nix61
1 files changed, 0 insertions, 61 deletions
diff --git a/Biz/Bot.nix b/Biz/Bot.nix
deleted file mode 100644
index 3b7710b..0000000
--- a/Biz/Bot.nix
+++ /dev/null
@@ -1,61 +0,0 @@
-{ options, lib, config, pkgs, ... }:
-
-let cfg = config.services.bizbot;
-in {
- options.services.bizbot = {
- enable = lib.mkEnableOption "Enable the bizbot service";
- package = lib.mkOption {
- type = lib.types.package;
- description = "bizbot package to use";
- };
- server = lib.mkOption {
- type = lib.types.str;
- description = "server address to connect to";
- };
- channel = lib.mkOption {
- type = lib.types.str;
- description = "channel to join";
- };
- dataDir = lib.mkOption {
- type = lib.types.str;
- description = "where bizbot will start it's ii tree";
- };
- };
- config = lib.mkIf cfg.enable {
- systemd.services = {
- "bizbot-${cfg.server}-${cfg.channel}-ii" = {
- wantedBy = [ "multi-user.target" ];
- path = [ pkgs.ii ];
- script = ''
- ${pkgs.ii}/bin/ii ${cfg.dataDir}/irc -s ${cfg.server} -p 6667 -n bizbot
- '';
- postStart = ''
- echo "/join ${cfg.channel}" > ${cfg.dataDir}/irc/${cfg.server}/in
- '';
- description = ''
- bizbot ii tree for ${cfg.server}/${cfg.channel}
- '';
-
- };
- "bizbot-${cfg.server}-${cfg.channel}" = {
- path = [ cfg.package ];
- wantedBy = [ "multi-user.target" ];
- after = [ "bizbot-${cfg.server}-${cfg.channel}-ii.service" ];
- script = ''
- tail -f ${cfg.dataDir}/irc/${cfg.server}/${cfg.channel}/out \
- | ${cfg.package}/bin/bizbot \
- | tee -a ${cfg.dataDir}/irc/${cfg.server}/${cfg.channel}/in
- '';
- description = ''
- bizbot for ${cfg.server}/${cfg.channel}
- '';
- serviceConfig = {
- KillSignal = "INT";
- Type = "simple";
- Restart = "on-abort";
- RestartSec = "1";
- };
- };
- };
- };
-}