summaryrefslogtreecommitdiff
path: root/Biz/Bot.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2021-04-02 21:39:47 -0400
committerBen Sima <ben@bsima.me>2021-04-02 21:39:47 -0400
commite3a813d72449e738bd95323511ad0696719bf396 (patch)
treedee2ff6b3be3037559b703bbf15a1769c00a88a6 /Biz/Bot.nix
parent574da8a4d081d19fd7b8447dc616d43786ef5f51 (diff)
Init bizbot
Diffstat (limited to 'Biz/Bot.nix')
-rw-r--r--Biz/Bot.nix68
1 files changed, 68 insertions, 0 deletions
diff --git a/Biz/Bot.nix b/Biz/Bot.nix
new file mode 100644
index 0000000..93aa2e6
--- /dev/null
+++ b/Biz/Bot.nix
@@ -0,0 +1,68 @@
+{ options
+, lib
+, config
+, pkgs
+, modulesPath
+}:
+
+let
+ cfg = config.services.bizbot;
+in
+{
+ options.services.bizbot = {
+ enable = lib.mkEnableOption "Enable the bizbot service";
+ package = lib.mkOption {
+ type = lib.types.package;
+ description = "bizbot package to use";
+ };
+ server = lib.mkOption {
+ type = lib.types.str;
+ description = "server address to connect to";
+ };
+ channel = lib.mkOption {
+ type = lib.types.str;
+ description = "channel to join";
+ };
+ dataDir = lib.mkOption {
+ type = lib.types.str;
+ description = "where bizbot will start it's ii tree";
+ };
+ };
+ config = lib.mkIf cfg.enable {
+ systemd.services = {
+ bizbot-${cfg.server}-${cfg.channel}-ii = {
+ wantedBy = [ "multi-user.target" ];
+ path = [ pkgs.ii ];
+ script = ''
+ ${pkgs.ii}/bin/ii ${cfg.dataDir}/irc -s ${cfg.server} -p 6667 -n bizbot
+ '';
+ postStart = ''
+ echo "/join ${cfg.channel}" > ${cfg.dataDir}/irc/${cfg.server}/in
+ '';
+ description = ''
+ bizbot ii tree for ${cfg.server}/${cfg.channel}
+ '';
+
+ };
+ bizbot-${cfg.server}-${cfg.channel} = {
+ path = [ cfg.package ];
+ wantedBy = [ "multi-user.target" ];
+ after = [ "bizbot-${cfg.server}-${cfg.channel}-ii.service" ];
+ script = ''
+ tail -f ${cfg.dataDir}/irc/${cfg.server}/${cfg.channel}/out \
+ | ${cfg.package}/bin/bizbot \
+ | tee -a ${cfg.dataDir}/irc/${cfg.server}/${cfg.channel}/in
+ '';
+ description = ''
+ bizbot for ${cfg.server}/${cfg.channel}
+ '';
+ serviceConfig = {
+ KillSignal = "INT";
+ Type = "simple";
+ Restart = "on-abort";
+ RestartSec = "1";
+ };
+ };
+ };
+ };
+}