summaryrefslogtreecommitdiff
path: root/Biz/Cloud/Gmnisrv.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-04-01 13:30:45 -0400
committerBen Sima <ben@bsima.me>2024-04-01 13:30:45 -0400
commitdb373a8c727cad91d375b40a6c70b11ed73bdafb (patch)
treea7ed24e98242b6e38f44cb0c9884718d248cc613 /Biz/Cloud/Gmnisrv.nix
parent5c8ef1bf4dff4fc7c6e66a57673a81477bcc850a (diff)
Add nixfmt to Lint.hs
nixfmt is the soon-to-be official formatter for Nix code, as per the NixOS GitHub group. So I figure I should just adopt it without worrying too much about the specifics of the formatting. I just formatted everything in one go, hence the huge diff, oh well.
Diffstat (limited to 'Biz/Cloud/Gmnisrv.nix')
-rw-r--r--Biz/Cloud/Gmnisrv.nix23
1 files changed, 9 insertions, 14 deletions
diff --git a/Biz/Cloud/Gmnisrv.nix b/Biz/Cloud/Gmnisrv.nix
index 2f7672b..e2a66f6 100644
--- a/Biz/Cloud/Gmnisrv.nix
+++ b/Biz/Cloud/Gmnisrv.nix
@@ -1,11 +1,6 @@
-{ lib
-, config
-, pkgs
-, ...
-}:
+{ lib, config, pkgs, ... }:
-let
- cfg = config.services.gmnisrv;
+let cfg = config.services.gmnisrv;
in {
meta.maintainers = [ lib.maintainers.bsima ];
options.services.gmnisrv = {
@@ -20,9 +15,7 @@ in {
Configuration for gmnisrv. See gmnisrv.ini(5) for supported settings.
'';
default = {
- ":tls" = {
- "store" = lib.mkDefault "${cfg.dataDir}/certs";
- };
+ ":tls" = { "store" = lib.mkDefault "${cfg.dataDir}/certs"; };
};
};
dataDir = lib.mkOption {
@@ -36,10 +29,12 @@ in {
description = "gmnisrv service";
wantedBy = [ "multi-user.target" ];
after = [ "network-online.target" ];
- script = let ini = lib.generators.toINIWithGlobalSection {} {
- globalSection = {"listen" = cfg.listen;};
- sections = cfg.settings;
- }; in "${pkgs.gmnisrv}/bin/gmnisrv -C ${ini}";
+ script = let
+ ini = lib.generators.toINIWithGlobalSection { } {
+ globalSection = { "listen" = cfg.listen; };
+ sections = cfg.settings;
+ };
+ in "${pkgs.gmnisrv}/bin/gmnisrv -C ${ini}";
};
};
}