summaryrefslogtreecommitdiff
path: root/Biz/Cloud/Hardware.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2021-10-17 11:52:47 -0400
committerBen Sima <ben@bsima.me>2021-11-26 13:47:38 -0500
commitf432b7057738cb5123c8e1b506a2a1199e71ee72 (patch)
treef9a1f2eda099530934ea1f56d58ea08ba25e304b /Biz/Cloud/Hardware.nix
parent8e1340bda701171e3557840332c4f3c30e1afc28 (diff)
Update cloud services
Rebuilt email server, started wireguard setup.
Diffstat (limited to 'Biz/Cloud/Hardware.nix')
-rw-r--r--Biz/Cloud/Hardware.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/Biz/Cloud/Hardware.nix b/Biz/Cloud/Hardware.nix
index 20eab30..ab775dc 100644
--- a/Biz/Cloud/Hardware.nix
+++ b/Biz/Cloud/Hardware.nix
@@ -1,8 +1,7 @@
-{ ... }:
+{ modulesPath, ... }:
{
+ imports = [ (modulesPath + "/profiles/qemu-guest.nix") ];
boot.loader.grub.device = "/dev/vda";
+ boot.initrd.kernelModules = [ "nvme" ];
fileSystems."/" = { device = "/dev/vda1"; fsType = "ext4"; };
- swapDevices = [
- { device = "/swapfile"; } # 4GB
- ];
}