summaryrefslogtreecommitdiff
path: root/Biz/Cloud/Networking.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-04-01 13:30:45 -0400
committerBen Sima <ben@bsima.me>2024-04-01 13:30:45 -0400
commitdb373a8c727cad91d375b40a6c70b11ed73bdafb (patch)
treea7ed24e98242b6e38f44cb0c9884718d248cc613 /Biz/Cloud/Networking.nix
parent5c8ef1bf4dff4fc7c6e66a57673a81477bcc850a (diff)
Add nixfmt to Lint.hs
nixfmt is the soon-to-be official formatter for Nix code, as per the NixOS GitHub group. So I figure I should just adopt it without worrying too much about the specifics of the formatting. I just formatted everything in one go, hence the huge diff, oh well.
Diffstat (limited to 'Biz/Cloud/Networking.nix')
-rw-r--r--Biz/Cloud/Networking.nix33
1 files changed, 25 insertions, 8 deletions
diff --git a/Biz/Cloud/Networking.nix b/Biz/Cloud/Networking.nix
index 05a1608..1c1f832 100644
--- a/Biz/Cloud/Networking.nix
+++ b/Biz/Cloud/Networking.nix
@@ -2,8 +2,7 @@
# This file was populated at runtime with the networking
# details gathered from the active system.
networking = {
- nameservers = [ "8.8.8.8"
- ];
+ nameservers = [ "8.8.8.8" ];
defaultGateway = "143.198.112.1";
defaultGateway6 = "2604:a880:400:d0::1";
dhcpcd.enable = false;
@@ -11,15 +10,33 @@
interfaces = {
eth0 = {
ipv4.addresses = [
- { address="143.198.118.179"; prefixLength=20; }
-{ address="10.10.0.7"; prefixLength=16; }
+ {
+ address = "143.198.118.179";
+ prefixLength = 20;
+ }
+ {
+ address = "10.10.0.7";
+ prefixLength = 16;
+ }
];
ipv6.addresses = [
- { address="2604:a880:400:d0::19f1:7001"; prefixLength=64; }
-{ address="fe80::a06e:26ff:fee1:941"; prefixLength=64; }
+ {
+ address = "2604:a880:400:d0::19f1:7001";
+ prefixLength = 64;
+ }
+ {
+ address = "fe80::a06e:26ff:fee1:941";
+ prefixLength = 64;
+ }
];
- ipv4.routes = [ { address = "143.198.112.1"; prefixLength = 32; } ];
- ipv6.routes = [ { address = "2604:a880:400:d0::1"; prefixLength = 128; } ];
+ ipv4.routes = [{
+ address = "143.198.112.1";
+ prefixLength = 32;
+ }];
+ ipv6.routes = [{
+ address = "2604:a880:400:d0::1";
+ prefixLength = 128;
+ }];
};
};