summaryrefslogtreecommitdiff
path: root/Biz/Cloud/NostrRelay.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-11-15 14:55:37 -0500
committerBen Sima <ben@bsima.me>2024-12-21 10:06:49 -0500
commit6513755670892983db88a6633b8c1ea6019c03d1 (patch)
tree44e9eccdb7a3a74ab7e96a8fee7572dd6a78dc73 /Biz/Cloud/NostrRelay.nix
parentae7b7e0186b5f2e0dcd4d5fac0a71fa264caedc2 (diff)
Re-namespace some stuff to Omni
I was getting confused about what is a product and what is internal infrastructure; I think it is good to keep those things separate. So I moved a bunch of stuff to an Omni namespace, actually most stuff went there. Only things that are explicitly external products are still in the Biz namespace.
Diffstat (limited to 'Biz/Cloud/NostrRelay.nix')
-rw-r--r--Biz/Cloud/NostrRelay.nix39
1 files changed, 0 insertions, 39 deletions
diff --git a/Biz/Cloud/NostrRelay.nix b/Biz/Cloud/NostrRelay.nix
deleted file mode 100644
index 0be8a6f..0000000
--- a/Biz/Cloud/NostrRelay.nix
+++ /dev/null
@@ -1,39 +0,0 @@
-{ config, pkgs, ... }:
-
-let
- ports = import ./Ports.nix;
- dataDir = "/var/lib/nostr-rs-relay";
- # https://git.sr.ht/~gheartsfield/nostr-rs-relay/tree/master/config.toml
- cfg = pkgs.writeText "config.toml" ''
- [info]
- name = "simatime"
- relay_url = "wss://nostr.simatime.com"
- description = "yet another nostr relay"
-
- [database]
- data_directory = "/var/lib/nostr-rs-relay"
-
- [network]
- address = "0.0.0.0"
- port = ${toString ports.nostr-relay}
- '';
-in {
- config.systemd.services.nostr-relay = {
- path = [ pkgs.nostr-rs-relay ];
- wantedBy = [ "multi-user.target" ];
- preStart = ''
- mkdir -p ${dataDir}
- cat "${cfg}" > ${dataDir}/config.toml
- '';
- script = "nostr-rs-relay --db ${dataDir}";
- serviceConfig = {
- Environment =
- [ "RUST_LOG=info,nostr_rs_relay=info" "APP_DATA=${dataDir}" ];
- WorkingDirectory = dataDir;
- KillSignal = "INT";
- Type = "simple";
- Restart = "always";
- RestartSec = "1";
- };
- };
-}