summaryrefslogtreecommitdiff
path: root/Biz/Cloud/NostrRelay.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-04-01 13:30:45 -0400
committerBen Sima <ben@bsima.me>2024-04-01 13:30:45 -0400
commitdb373a8c727cad91d375b40a6c70b11ed73bdafb (patch)
treea7ed24e98242b6e38f44cb0c9884718d248cc613 /Biz/Cloud/NostrRelay.nix
parent5c8ef1bf4dff4fc7c6e66a57673a81477bcc850a (diff)
Add nixfmt to Lint.hs
nixfmt is the soon-to-be official formatter for Nix code, as per the NixOS GitHub group. So I figure I should just adopt it without worrying too much about the specifics of the formatting. I just formatted everything in one go, hence the huge diff, oh well.
Diffstat (limited to 'Biz/Cloud/NostrRelay.nix')
-rw-r--r--Biz/Cloud/NostrRelay.nix6
1 files changed, 2 insertions, 4 deletions
diff --git a/Biz/Cloud/NostrRelay.nix b/Biz/Cloud/NostrRelay.nix
index 73c1366..0be8a6f 100644
--- a/Biz/Cloud/NostrRelay.nix
+++ b/Biz/Cloud/NostrRelay.nix
@@ -27,10 +27,8 @@ in {
'';
script = "nostr-rs-relay --db ${dataDir}";
serviceConfig = {
- Environment = [
- "RUST_LOG=info,nostr_rs_relay=info"
- "APP_DATA=${dataDir}"
- ];
+ Environment =
+ [ "RUST_LOG=info,nostr_rs_relay=info" "APP_DATA=${dataDir}" ];
WorkingDirectory = dataDir;
KillSignal = "INT";
Type = "simple";