summaryrefslogtreecommitdiff
path: root/Biz/Cloud/Web.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2021-04-20 17:22:32 -0400
committerBen Sima <ben@bsima.me>2021-11-26 13:47:34 -0500
commit2b307499382691e3b4391b7accd9030cfadb0dd4 (patch)
tree093e65358c687b38cf0e34554857bef73de8c511 /Biz/Cloud/Web.nix
parent6603960da6fd4bf2e65d844da116e0f507e541d3 (diff)
Publish and archive some git repos
Also adds a post-receive script that creates and publishes a git-archive of the repo at that commit. This way I can depend on my own nixpkgs fork. It took me forever but I finally figured out that I need --prefix in the git archive. I also switched to using gzip instead of xz because its faster, and I figured out how to get the sha256 that nix expects, so I can now just copy that and paste it into Biz/Bild/Sources.json.
Diffstat (limited to 'Biz/Cloud/Web.nix')
-rw-r--r--Biz/Cloud/Web.nix22
1 files changed, 17 insertions, 5 deletions
diff --git a/Biz/Cloud/Web.nix b/Biz/Cloud/Web.nix
index bc0d921..cba8b2f 100644
--- a/Biz/Cloud/Web.nix
+++ b/Biz/Cloud/Web.nix
@@ -12,10 +12,10 @@ in
listen = "0.0.0.0:1965 [::]:1965";
":tls" = { store = "/var/lib/gmnisrv"; };
"bsima.me" = {
- "root" = "/www/ben/public";
+ "root" = "/srv/www/ben";
};
"simatime.com" = {
- "root" = "/www/simatime.com/public";
+ "root" = "/srv/www/simatime.com";
"cgi" = "on";
};
};
@@ -34,11 +34,23 @@ in
virtualHosts = {
${rootDomain} = {
- locations."/".root = "/srv/www/";
+ locations."/archive.*" = {
+ root = "/srv/www/simatime.com/archive";
+ extraConfig = ''
+ autoindex on;
+ '';
+ };
+
+ locations."/" = {
+ root = "/srv/www/simatime.com";
+ extraConfig = ''
+ autoindex on;
+ '';
+ };
# serve /~$USER paths
locations."~ ^/~(.+?)(/.*)?$" = {
- alias = "/www/$1/public$2";
+ alias = "/srv/www/$1$2";
index = "index.html index.htm";
extraConfig = ''
autoindex on;
@@ -50,7 +62,7 @@ in
"bsima.me" = {
locations."/" = {
- root = "/www/ben/public";
+ root = "/srv/www/ben";
index = "index.html index.htm";
extraConfig = ''
autoindex on;