summaryrefslogtreecommitdiff
path: root/Biz/Cloud/Web.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2020-12-29 22:29:57 -0500
committerBen Sima <ben@bsima.me>2020-12-29 22:29:57 -0500
commit36eac84f40aa938fd9327ddf4f983736ff550bcf (patch)
tree75da57d82a42e5039227ac8605b004e8e251a6c4 /Biz/Cloud/Web.nix
parentb11e926cf60672c17b462ad142014946063f4136 (diff)
Deploy hoogle to Biz.Dev
I had to refactor Biz/Bild/Rules.nix. I also had to checkin my patched hoogle.nix file, but I also upstreamed the patch to nixpkgs-dev so it shouldn't stick around for too long.
Diffstat (limited to 'Biz/Cloud/Web.nix')
-rw-r--r--Biz/Cloud/Web.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/Biz/Cloud/Web.nix b/Biz/Cloud/Web.nix
index 56eeb2d..81f3cf0 100644
--- a/Biz/Cloud/Web.nix
+++ b/Biz/Cloud/Web.nix
@@ -44,6 +44,12 @@ in
useACMEHost = rootDomain;
};
+ "hoogle.${rootDomain}" = {
+ locations."/".proxyPass = "http://${bensIp}:8008";
+ forceSSL = true;
+ useACMEHost = rootDomain;
+ };
+
"tv.${rootDomain}" = {
locations."/".proxyPass = "http://${bensIp}:8096"; # emby runs on port 8096
forceSSL = true;
@@ -81,5 +87,6 @@ in
"devalloc.io"
"matrix.${rootDomain}"
"chat.${rootDomain}"
+ "hoogle.${rootDomain}"
];#
}