summaryrefslogtreecommitdiff
path: root/Biz/Cloud/Web.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2021-08-23 13:06:15 -0400
committerBen Sima <ben@bsima.me>2021-11-26 13:47:38 -0500
commit45f352f9cb3bdc16048a0f0d70eef6a59272472b (patch)
tree7cae4b608e45360085d950d7c14d80911ce46b7c /Biz/Cloud/Web.nix
parentaa2eb2d3e08fb74b93acc9608a78582834a65e8c (diff)
Fix GitHub OAuth args
This makes it explicit that we are using GitHub vs some other OAuth args. The idea is that we should be making a new type for every service, this allows us to have type safety in the implementation but a common set or pattern of names for the environment variables and record fields. Also using 'notset' instead of 'mempty' is really helpful for debugging when this breaks, as I found out.
Diffstat (limited to 'Biz/Cloud/Web.nix')
-rw-r--r--Biz/Cloud/Web.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/Biz/Cloud/Web.nix b/Biz/Cloud/Web.nix
index 853c967..9899258 100644
--- a/Biz/Cloud/Web.nix
+++ b/Biz/Cloud/Web.nix
@@ -118,6 +118,12 @@ in
useACMEHost = rootDomain;
};
+ "devalloc.io" = {
+ forceSSL = true;
+ useACMEHost = rootDomain;
+ globalRedirect = "dragons.dev";
+ };
+
"dragons.dev" = {
locations."/".proxyPass = "http://${ports.bensIp}:${toString ports.dragons}";
forceSSL = true;
@@ -166,7 +172,7 @@ in
# This must contain all of the other domains we host
security.acme.certs.${rootDomain}.extraDomainNames = [
"bsima.me" "www.bsima.me"
- "dragons.dev"
+ "dragons.dev" "devalloc.io"
] ++ map (sub: "${sub}.${rootDomain}") [
"tv"
"matrix"