summaryrefslogtreecommitdiff
path: root/Biz/Cloud/Web.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2023-01-03 14:25:59 -0500
committerBen Sima <ben@bsima.me>2023-01-03 15:06:38 -0500
commit52fd37e2ac382a2630d3fe3d22ef86908d67a6b6 (patch)
treed866098af16bbea4e007f5867e21298a8866528a /Biz/Cloud/Web.nix
parentad02b2b02da71f0a71c9dcc8bd595afec8e4bee7 (diff)
Add mumble and botamusique services
Diffstat (limited to 'Biz/Cloud/Web.nix')
-rw-r--r--Biz/Cloud/Web.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/Biz/Cloud/Web.nix b/Biz/Cloud/Web.nix
index 373af96..5f4789a 100644
--- a/Biz/Cloud/Web.nix
+++ b/Biz/Cloud/Web.nix
@@ -195,6 +195,12 @@ in
};
};
+ "music.${rootDomain}" = {
+ forceSSL = true;
+ useACMEHost = rootDomain;
+ locations."/".proxyPass = "http://localhost:${toString ports.botamusique}";
+ };
+
"notebook.${rootDomain}" = {
forceSSL = true;
useACMEHost = rootDomain;
@@ -224,6 +230,7 @@ in
"dragons.dev"
"nixpert.chat"
] ++ map (sub: "${sub}.${rootDomain}") [
+ "music"
"tv"
"matrix"
"chat"