summaryrefslogtreecommitdiff
path: root/Biz/Cloud/Web.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2021-04-02 21:33:45 -0400
committerBen Sima <ben@bsima.me>2021-04-02 21:33:45 -0400
commit574da8a4d081d19fd7b8447dc616d43786ef5f51 (patch)
tree2b30115e704dd1979b4f0acc45e2f32b2487a626 /Biz/Cloud/Web.nix
parent2444dbaa079902f243744c0861d33cab9d1e5c4f (diff)
Get my static site working again
Diffstat (limited to 'Biz/Cloud/Web.nix')
-rw-r--r--Biz/Cloud/Web.nix8
1 files changed, 5 insertions, 3 deletions
diff --git a/Biz/Cloud/Web.nix b/Biz/Cloud/Web.nix
index c364c22..74fc27e 100644
--- a/Biz/Cloud/Web.nix
+++ b/Biz/Cloud/Web.nix
@@ -12,8 +12,10 @@ in
recommendedOptimisation = true;
recommendedProxySettings = true;
recommendedTlsSettings = true;
+ statusPage = true;
- group = "users";
+ user = "nginx";
+ group = "www-data";
virtualHosts = {
${rootDomain} = {
@@ -21,7 +23,7 @@ in
# serve /~$USER paths
locations."~ ^/~(.+?)(/.*)?$" = {
- alias = "/home/$1/public_html$2";
+ alias = "/www/$1/public$2";
index = "index.html index.htm";
extraConfig = ''
autoindex on;
@@ -33,7 +35,7 @@ in
"bsima.me" = {
locations."/" = {
- root = "/home/ben/public_html/";
+ root = "/www/ben/public";
index = "index.html index.htm";
extraConfig = ''
autoindex on;