summaryrefslogtreecommitdiff
path: root/Biz/Cloud/Web.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2021-06-11 07:59:14 -0400
committerBen Sima <ben@bsima.me>2021-11-26 13:47:35 -0500
commit6e1f615b4b0e36b98d179dc4bcab79acdc200c56 (patch)
tree08800893ac874c99a078267cde8e2d24b7b7e022 /Biz/Cloud/Web.nix
parent72a7aaa39e7552970f466e712e1f7ef91aeb03c8 (diff)
Deploy grocy
Diffstat (limited to 'Biz/Cloud/Web.nix')
-rw-r--r--Biz/Cloud/Web.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/Biz/Cloud/Web.nix b/Biz/Cloud/Web.nix
index 2a47fc1..fd28eee 100644
--- a/Biz/Cloud/Web.nix
+++ b/Biz/Cloud/Web.nix
@@ -42,7 +42,7 @@ in
statusPage = true;
user = "nginx";
- group = "www-data";
+ group = "nginx";
virtualHosts = {
${rootDomain} = {
@@ -152,6 +152,10 @@ in
# proxyWebsockets = true;
# };
#};
+ "grocy.${rootDomain}" = {
+ useACMEHost = rootDomain;
+ forceSSL = true;
+ };
};
};
};
@@ -166,5 +170,6 @@ in
"dandel-rovbur.${rootDomain}"
"sabten.${rootDomain}"
"cal.${rootDomain}"
+ "grocy.${rootDomain}"
];#
}