summaryrefslogtreecommitdiff
path: root/Biz/Cloud/Web.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2022-07-27 14:57:55 -0400
committerBen Sima <ben@bsima.me>2022-07-27 14:57:55 -0400
commita988b5cc9d75ad23a23b0b34b35f00bdacc9a2e2 (patch)
treef32456fb34f4fc381f1352082dddf5bfcb3a0a58 /Biz/Cloud/Web.nix
parent2d753c6120ccf47734fba8fb1588408df1fdf5c0 (diff)
Upgrade nixpkgs
Diffstat (limited to 'Biz/Cloud/Web.nix')
-rw-r--r--Biz/Cloud/Web.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/Biz/Cloud/Web.nix b/Biz/Cloud/Web.nix
index a096779..e0b9a95 100644
--- a/Biz/Cloud/Web.nix
+++ b/Biz/Cloud/Web.nix
@@ -1,10 +1,11 @@
-{ config, ... }:
+{ config, pkgs, ... }:
let
rootDomain = config.networking.domain;
ports = import ./Ports.nix;
in
{
+ imports = [ ./Gmnisrv.nix ];
networking.firewall = {
allowedTCPPorts = [
ports.ssh
@@ -36,6 +37,7 @@ in
};
};
gmnisrv = {
+ package = pkgs.gmnisrv;
enable = true;
settings = {
listen = "0.0.0.0:${toString ports.gemini} [::]:${toString ports.gemini}";