summaryrefslogtreecommitdiff
path: root/Biz/Cloud/Web.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2021-07-12 09:51:28 -0400
committerBen Sima <ben@bsima.me>2021-11-26 13:47:36 -0500
commitce1f39471d090d724d33732a6ea995213666dbf9 (patch)
treed7ccc5f74a7c8899410efad890a1c04884ad23fa /Biz/Cloud/Web.nix
parent1934482e8a5beb628b1e6e9db11f9fd274f174a5 (diff)
Enable jupyter, consolidate ports, open bitcoind
Diffstat (limited to 'Biz/Cloud/Web.nix')
-rw-r--r--Biz/Cloud/Web.nix64
1 files changed, 35 insertions, 29 deletions
diff --git a/Biz/Cloud/Web.nix b/Biz/Cloud/Web.nix
index fd28eee..5a14fb4 100644
--- a/Biz/Cloud/Web.nix
+++ b/Biz/Cloud/Web.nix
@@ -2,7 +2,6 @@
let
rootDomain = config.networking.domain;
- bensIp = "199.26.245.64";
ports = import ./Ports.nix;
in
{
@@ -102,13 +101,13 @@ in
};
"hoogle.${rootDomain}" = {
- locations."/".proxyPass = "http://${bensIp}:${toString ports.hoogle}";
+ locations."/".proxyPass = "http://${ports.bensIp}:${toString ports.hoogle}";
forceSSL = true;
useACMEHost = rootDomain;
};
"tv.${rootDomain}" = {
- locations."/".proxyPass = "http://${bensIp}:${toString ports.jellyfin}";
+ locations."/".proxyPass = "http://${ports.bensIp}:${toString ports.jellyfin}";
forceSSL = true;
useACMEHost = rootDomain;
};
@@ -120,13 +119,13 @@ in
};
"devalloc.io" = {
- locations."/".proxyPass = "http://${bensIp}:${toString ports.devalloc}";
+ locations."/".proxyPass = "http://${ports.bensIp}:${toString ports.devalloc}";
forceSSL = true;
useACMEHost = rootDomain;
};
"dandel-rovbur.${rootDomain}" = {
- locations."/".proxyPass = "http://${bensIp}:${toString ports.dandel-rovbur}";
+ locations."/".proxyPass = "http://${ports.bensIp}:${toString ports.dandel-rovbur}";
forceSSL = true;
useACMEHost = rootDomain;
};
@@ -137,21 +136,25 @@ in
useACMEHost = rootDomain;
};
- # Jupyter is currently disabled on Biz.Dev
- #"notebook.simatime.com".locations = {
- # "/" = {
- # proxyPass = "http://${bensIp}:3099";
- # proxyWebsockets = true;
- # extraConfig = ''
- # proxy_buffering off;
- # proxy_read_timeout 86400;
- # '';
- # };
- # "/(api/kernels/[^/]+/channels|terminals/websocket)/" = {
- # proxyPass = "http://${bensIp}:3099";
- # proxyWebsockets = true;
- # };
- #};
+ "notebook.simatime.com" = {
+ forceSSL = true;
+ useACMEHost = rootDomain;
+ locations = {
+ "/" = {
+ proxyPass = "http://${ports.bensIp}:${toString ports.jupyter}";
+ proxyWebsockets = true;
+ extraConfig = ''
+ proxy_buffering off;
+ proxy_read_timeout 86400;
+ '';
+ };
+ "/(api/kernels/[^/]+/channels|terminals/websocket)/" = {
+ proxyPass = "http://${ports.bensIp}:${toString ports.jupyter}";
+ proxyWebsockets = true;
+ };
+ };
+ };
+
"grocy.${rootDomain}" = {
useACMEHost = rootDomain;
forceSSL = true;
@@ -162,14 +165,17 @@ in
# This must contain all of the other domains we host
security.acme.certs.${rootDomain}.extraDomainNames = [
- "bsima.me" "www.bsima.me" "tv.${rootDomain}"
+ "bsima.me" "www.bsima.me"
"devalloc.io"
- "matrix.${rootDomain}"
- "chat.${rootDomain}"
- "hoogle.${rootDomain}"
- "dandel-rovbur.${rootDomain}"
- "sabten.${rootDomain}"
- "cal.${rootDomain}"
- "grocy.${rootDomain}"
- ];#
+ ] ++ map (sub: "${sub}.${rootDomain}") [
+ "tv"
+ "matrix"
+ "chat"
+ "hoogle"
+ "dandel-rovbur"
+ "sabten"
+ "cal"
+ "notebook"
+ "grocy"
+ ];
}