summaryrefslogtreecommitdiff
path: root/Biz/Cloud/Web.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2021-10-17 11:52:47 -0400
committerBen Sima <ben@bsima.me>2021-11-26 13:47:38 -0500
commitf432b7057738cb5123c8e1b506a2a1199e71ee72 (patch)
treef9a1f2eda099530934ea1f56d58ea08ba25e304b /Biz/Cloud/Web.nix
parent8e1340bda701171e3557840332c4f3c30e1afc28 (diff)
Update cloud services
Rebuilt email server, started wireguard setup.
Diffstat (limited to 'Biz/Cloud/Web.nix')
-rw-r--r--Biz/Cloud/Web.nix28
1 files changed, 18 insertions, 10 deletions
diff --git a/Biz/Cloud/Web.nix b/Biz/Cloud/Web.nix
index 9899258..68ff19e 100644
--- a/Biz/Cloud/Web.nix
+++ b/Biz/Cloud/Web.nix
@@ -5,6 +5,19 @@ let
ports = import ./Ports.nix;
in
{
+ networking.firewall = {
+ allowedTCPPorts = [
+ ports.ssh
+ ports.git
+ ports.http
+ ports.https
+ ports.sabten
+ ports.gemini
+ ports.radicale
+ ports.znc
+ ];
+ };
+
services = {
radicale = {
enable = true;
@@ -23,10 +36,10 @@ in
listen = "0.0.0.0:${toString ports.gemini} [::]:${toString ports.gemini}";
":tls" = { store = "/var/lib/gmnisrv"; };
"bsima.me" = {
- "root" = "/srv/www/ben";
+ "root" = "/var/web/ben";
};
"simatime.com" = {
- "root" = "/srv/www/simatime.com";
+ "root" = "/var/web/simatime.com";
"cgi" = "on";
};
};
@@ -49,14 +62,14 @@ in
enableACME = true;
locations = {
"/" = {
- root = "/srv/www/simatime.com";
+ root = "/var/web/simatime.com";
extraConfig = ''
autoindex on;
'';
};
# serve /~$USER paths
"~ ^/~(.+?)(/.*)?$" = {
- alias = "/srv/www/$1$2";
+ alias = "/var/web/$1$2";
index = "index.html index.htm";
extraConfig = ''
autoindex on;
@@ -89,7 +102,7 @@ in
"bsima.me" = {
locations."/" = {
- root = "/srv/www/ben";
+ root = "/var/web/ben";
index = "index.html index.htm";
extraConfig = ''
autoindex on;
@@ -161,10 +174,6 @@ in
};
};
- "grocy.${rootDomain}" = {
- useACMEHost = rootDomain;
- forceSSL = true;
- };
};
};
};
@@ -182,6 +191,5 @@ in
"sabten"
"cal"
"notebook"
- "grocy"
];
}