summaryrefslogtreecommitdiff
path: root/Biz/Cloud/Web.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2023-11-13 22:52:21 -0500
committerBen Sima <ben@bsima.me>2023-11-13 22:52:21 -0500
commitf86874ef2092ffcd51089b1695cf8aeaa4fb2a0b (patch)
tree545792a2225e5304d1c9ee57957353b0228acb38 /Biz/Cloud/Web.nix
parent2b4f700d7ec4ba7426119ff2404094a6fd1fe53c (diff)
Update radicale and set recommended headers
This was leftover from work on the previous commit. I don't think its actually needed to get my stuff working, but these headers are recommended in the docs and the latest version supposedly has some relevant bug fixes, so I decided to commit this. - https://github.com/Kozea/Radicale/issues/838 - https://github.com/Kozea/Radicale/issues/954 - https://github.com/Kozea/Radicale/issues/1247
Diffstat (limited to 'Biz/Cloud/Web.nix')
-rw-r--r--Biz/Cloud/Web.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/Biz/Cloud/Web.nix b/Biz/Cloud/Web.nix
index 532c843..f97f6e0 100644
--- a/Biz/Cloud/Web.nix
+++ b/Biz/Cloud/Web.nix
@@ -164,6 +164,12 @@ in
locations."/".proxyPass = "http://localhost:${toString ports.radicale}";
forceSSL = true;
useACMEHost = rootDomain;
+ extraConfig = ''
+ proxy_set_header X-Script-Name /radicale;
+ proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
+ proxy_set_header Host $host;
+ proxy_pass_header Authorization;
+ '';
};
"reddit.${rootDomain}" = {