summaryrefslogtreecommitdiff
path: root/Biz/Cloud/hardware.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2020-04-19 18:41:53 -0700
committerBen Sima <ben@bsima.me>2020-04-19 18:41:53 -0700
commite68396459ecc5b04702117db5b24521b3a5014d3 (patch)
tree3db3cb275fec0d9194d6c2b663623adc6dbc096a /Biz/Cloud/hardware.nix
parente6aafc7d9abbb4252a5cb41d4da2cd134de61cfc (diff)
Add swap to my cloud server
Diffstat (limited to 'Biz/Cloud/hardware.nix')
-rw-r--r--Biz/Cloud/hardware.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/Biz/Cloud/hardware.nix b/Biz/Cloud/hardware.nix
index 8c88cb7..458fd49 100644
--- a/Biz/Cloud/hardware.nix
+++ b/Biz/Cloud/hardware.nix
@@ -3,4 +3,7 @@
imports = [ <nixpkgs/nixos/modules/profiles/qemu-guest.nix> ];
boot.loader.grub.device = "/dev/vda";
fileSystems."/" = { device = "/dev/vda1"; fsType = "ext4"; };
+ swapDevices = [
+ { device = "/swapfile"; } # 4GB
+ ];
}