summaryrefslogtreecommitdiff
path: root/Biz/Cloud/web.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2020-11-16 11:47:36 -0500
committerBen Sima <ben@bsima.me>2020-11-16 11:47:36 -0500
commit656816ed9af6277bbeb1c5e74471bace3a78e5be (patch)
tree8d9b28d4a804fdb258f17b32e675bf9a4dcf8a98 /Biz/Cloud/web.nix
parenteb3ee6f1867eb19d2a262826038b2615b3def762 (diff)
get build working and capitalize more files
Diffstat (limited to 'Biz/Cloud/web.nix')
-rw-r--r--Biz/Cloud/web.nix41
1 files changed, 0 insertions, 41 deletions
diff --git a/Biz/Cloud/web.nix b/Biz/Cloud/web.nix
deleted file mode 100644
index acd5c2f..0000000
--- a/Biz/Cloud/web.nix
+++ /dev/null
@@ -1,41 +0,0 @@
-{ ... }:
-
-let
- bensIp = "24.140.84.23";
-in
-{
- services = {
- nginx = {
- enable = true;
- recommendedGzipSettings = true;
- recommendedOptimisation = true;
- recommendedProxySettings = true;
- recommendedTlsSettings = true;
- virtualHosts = {
- "bsima.me".root = "/home/ben/public_html/";
- "www.bsima.me".root = "/home/ben/public_html/";
- "simatime.com".locations."/".root = "/srv/www/";
- "firefoxsync.simatime.com".locations."/".proxyPass = "http://localhost:5001";
- "hero.simatime.com".locations."/".proxyPass = "http://${bensIp}:3001";
- "tv.simatime.com".locations."/".proxyPass = "http://${bensIp}:8096"; # emby runs on port 8096
- "deluge.simatime.com".locations."/".proxyPass = "http://${bensIp}:8112";
-
- "notebook.simatime.com".locations = {
- "/" = {
- proxyPass = "http://${bensIp}:3099";
- proxyWebsockets = true;
- extraConfig = ''
- proxy_buffering off;
- proxy_read_timeout 86400;
-
- '';
- };
- "/(api/kernels/[^/]+/channels|terminals/websocket)/" = {
- proxyPass = "http://${bensIp}:3099";
- proxyWebsockets = true;
- };
- };
- };
- };
- };
-}