summaryrefslogtreecommitdiff
path: root/Biz/Dev/Beryllium/Ollama.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-11-15 14:55:37 -0500
committerBen Sima <ben@bsima.me>2024-12-21 10:06:49 -0500
commit6513755670892983db88a6633b8c1ea6019c03d1 (patch)
tree44e9eccdb7a3a74ab7e96a8fee7572dd6a78dc73 /Biz/Dev/Beryllium/Ollama.nix
parentae7b7e0186b5f2e0dcd4d5fac0a71fa264caedc2 (diff)
Re-namespace some stuff to Omni
I was getting confused about what is a product and what is internal infrastructure; I think it is good to keep those things separate. So I moved a bunch of stuff to an Omni namespace, actually most stuff went there. Only things that are explicitly external products are still in the Biz namespace.
Diffstat (limited to 'Biz/Dev/Beryllium/Ollama.nix')
-rw-r--r--Biz/Dev/Beryllium/Ollama.nix48
1 files changed, 0 insertions, 48 deletions
diff --git a/Biz/Dev/Beryllium/Ollama.nix b/Biz/Dev/Beryllium/Ollama.nix
deleted file mode 100644
index 35b4fe1..0000000
--- a/Biz/Dev/Beryllium/Ollama.nix
+++ /dev/null
@@ -1,48 +0,0 @@
-{ pkgs, ... }:
-/* Ollama API service
-
- Don't put too much work into this, there's a much better and more complete
- ollama service (with webui!) being built here:
- https://github.com/NixOS/nixpkgs/pull/275448
-
- If you want to spend time on it, spend time over there.
-*/
-let pkg = pkgs.unstable.ollama;
-in {
-
- systemd.services.ollama = {
- description = "ollama";
- after = [ "network.target" ];
- wantedBy = [ "multi-user.target" ];
-
- environment = {
- OLLAMA_HOST = "localhost:11434";
- # Where to store LLM model files.
- HOME = "%S/ollama";
- OLLAMA_MODELS = "%S/ollama/models";
- OLLAMA_DEBUG = "1";
- };
-
- serviceConfig = {
- ExecStart = "${pkg}/bin/ollama serve";
- User = "ollama";
- Group = "ollama";
- Type = "simple";
- Restart = "on-failure";
- RestartSec = 3;
- # Persistent storage for model files, i.e. /var/lib/<StateDirectory>
- StateDirectory = [ "ollama" ];
- };
- };
-
- # for administration, make this available to users' PATH
- environment.systemPackages = [ pkg ];
-
- users.groups.ollama = { };
-
- users.users.ollama = {
- group = "ollama";
- isSystemUser = true;
- extraGroups = [ "render" "video" ];
- };
-}