summaryrefslogtreecommitdiff
path: root/Biz/Dev/Dns.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2023-10-10 13:15:59 -0400
committerBen Sima <ben@bsima.me>2023-10-10 13:15:59 -0400
commit904de577261e7024373e7a42fd763184764238f9 (patch)
tree563e4968eab568466ae3e7a1c747dd24a77986c0 /Biz/Dev/Dns.nix
parent6107f8178e26ada67e5d5ec60501e24528b3db56 (diff)
Don't swallow namespace-parsing errors
Previously, if there was a problem with the inputs and bild failed to determine the namespace, 'fromPath' would return 'Nothing' and then 'catMaybes' would drop the error-causing input altogether. In the one time that I had a bad input, this made debugging incredibly difficult. It's always a bad idea to swallow errors silently, so instead lets just kill the program if we have bad inputs.
Diffstat (limited to 'Biz/Dev/Dns.nix')
-rw-r--r--Biz/Dev/Dns.nix8
1 files changed, 0 insertions, 8 deletions
diff --git a/Biz/Dev/Dns.nix b/Biz/Dev/Dns.nix
index 4720b39..0490ead 100644
--- a/Biz/Dev/Dns.nix
+++ b/Biz/Dev/Dns.nix
@@ -18,14 +18,6 @@
extraOptions = ''
dnssec-validation auto;
'';
- zones = [
- {
- master = true;
- name = "home";
- slaves = [];
- file = ./Home.zone;
- }
- ];
};
#networking.extraHosts = ''