summaryrefslogtreecommitdiff
path: root/Biz/Dev/Guix.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-11-15 14:55:37 -0500
committerBen Sima <ben@bsima.me>2024-12-21 10:06:49 -0500
commit6513755670892983db88a6633b8c1ea6019c03d1 (patch)
tree44e9eccdb7a3a74ab7e96a8fee7572dd6a78dc73 /Biz/Dev/Guix.nix
parentae7b7e0186b5f2e0dcd4d5fac0a71fa264caedc2 (diff)
Re-namespace some stuff to Omni
I was getting confused about what is a product and what is internal infrastructure; I think it is good to keep those things separate. So I moved a bunch of stuff to an Omni namespace, actually most stuff went there. Only things that are explicitly external products are still in the Biz namespace.
Diffstat (limited to 'Biz/Dev/Guix.nix')
-rw-r--r--Biz/Dev/Guix.nix43
1 files changed, 0 insertions, 43 deletions
diff --git a/Biz/Dev/Guix.nix b/Biz/Dev/Guix.nix
deleted file mode 100644
index 0b261fb..0000000
--- a/Biz/Dev/Guix.nix
+++ /dev/null
@@ -1,43 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-with lib;
-
-let
-
- cfg = config.services.guix;
-
-in {
-
- options.services.guix = {
- enable = mkEnableOption "GNU Guix package manager";
- };
-
- config = mkIf cfg.enable {
- systemd.services.guix-daemon = {
- description = "Build daemon for GNU Guix";
-
- wantedBy = [ "multi-user.target" ];
-
- serviceConfig = {
- Restart = "always";
- ExecStart =
- "${pkgs.guix}/bin/guix-daemon --build-users-group=guixbuild";
- Environment = null;
- RemainAfterExit = "yes";
- StandardOutput = "syslog";
- StandardError = "syslog";
- TaskMax = "8192";
- };
- };
- users = {
- extraUsers = lib.attrs.genAttrs (lib.lists.range 1 10) (n: {
- name = "guixbuilder${n}";
- isSystemUser = true;
- extraGroups = [ "guixbuild" ];
- group = "guixbuild";
- description = "Guix build user ${n}";
- });
- extraGroups = { "guixbuild" = { }; };
- };
- };
-}