summaryrefslogtreecommitdiff
path: root/Biz/Dev/Networking.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2021-12-21 11:00:53 -0500
committerBen Sima <ben@bsima.me>2021-12-21 11:01:55 -0500
commit2b4e0164beaf697332cebce9c9a088be1978ffc5 (patch)
tree1c353bd9dd559074f616220447dc95bcc9369ee9 /Biz/Dev/Networking.nix
parentf8197182cc5c2482781c2d02fc8e05ba75d00c09 (diff)
Reorganize some nix code
Diffstat (limited to 'Biz/Dev/Networking.nix')
-rw-r--r--Biz/Dev/Networking.nix52
1 files changed, 52 insertions, 0 deletions
diff --git a/Biz/Dev/Networking.nix b/Biz/Dev/Networking.nix
new file mode 100644
index 0000000..150b098
--- /dev/null
+++ b/Biz/Dev/Networking.nix
@@ -0,0 +1,52 @@
+{ config, lib, pkgs, ... }:
+
+let
+ ports = import ../Cloud/Ports.nix;
+in {
+ networking = {
+ nameservers = [ "1.1.1.1" ];
+ hostName = "lithium";
+ hosts = {
+ "::1" = [ "localhost" "ipv6-localhost" "ipv6-loopback" ];
+ };
+
+ firewall = {
+ allowedTCPPorts = [
+ ports.bitcoind
+ ports.delugeWeb
+ ports.et
+ ports.gemini
+ ports.git
+ ports.http
+ ports.https
+ ports.jellyfin
+ ports.jupyter
+ ports.k3s
+ ports.mpd
+ ports.mpd-stream
+ ports.murmur
+ ports.radicale
+ ports.sabten
+ ports.ssh
+ ports.tor
+ ];
+ allowedTCPPortRanges = [
+ ports.torrents
+ ports.httpdev
+ ];
+ allowedUDPPorts = [ ports.murmur ports.et ];
+ allowedUDPPortRanges = [
+ ports.torrents
+ ];
+ checkReversePath = false;
+ };
+
+ # The global useDHCP flag is deprecated, therefore explicitly set to false here.
+ # Per-interface useDHCP will be mandatory in the future, so this generated config
+ # replicates the default behaviour.
+ useDHCP = false;
+ interfaces.enp1s0.useDHCP = true;
+ interfaces.wlp0s20f0u4.useDHCP = true;
+ };
+
+}