summaryrefslogtreecommitdiff
path: root/Biz/Dev/Vpn.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-12-21 10:40:06 -0400
committerBen Sima <ben@bsima.me>2024-12-21 09:40:06 -0500
commit79390d4eea20ca15fd8e088345528f31ed5fad1e (patch)
treef08b71ffddead23484fd6df9e1aff54d20f12768 /Biz/Dev/Vpn.nix
parent18956baad9cde85bc55bd0113092e51786d9e1ee (diff)
Upgrade to nixos-24.05
I think this is the only "supported" nixos version now. But in any case scipy seemed to be broken on the older version, and I couldn't build my code that uses llm. Also, this allows me to get rid of the bild.os-unstable thing for Beryllium, which was just a sitting timebomb of breaking stuff. There are a lot of changes here because ruff updated to the very latest, and it changed some minor lint things. Also with the new nixos I get a proper cgit module, and some other breaking changes needed fixing.
Diffstat (limited to 'Biz/Dev/Vpn.nix')
-rw-r--r--Biz/Dev/Vpn.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/Biz/Dev/Vpn.nix b/Biz/Dev/Vpn.nix
index 47f9c6e..9b791b7 100644
--- a/Biz/Dev/Vpn.nix
+++ b/Biz/Dev/Vpn.nix
@@ -8,7 +8,7 @@ in {
enable = true;
address = "0.0.0.0";
port = ports.headscale;
- settings = { };
+ settings = { dns.base_domain = "simatime.com"; };
};
services.nginx.virtualHosts.${domain} = {